cancel
Showing results for 
Search instead for 
Did you mean: 

Disable keypad on laptop

MarkSyder
Honored Contributor

Disable keypad on laptop

Hi everybody.My family's laptop is driving us all crazy. The keypad appears to be jammed in the "on" position, which means it's always registering mouse clicks even when no one actually touches it.I've attached a USB mouse so we don't need to use the keypad but it hasn't made any difference.Is there any way to disable the keypad so we can just use the mouse? The laptop is made by Maxdata, just in case different makes disable the keypad in different ways.Mark Syder (like the drink but spelt different)
The triumph of evil requires only that good men do nothing
4 REPLIES
Ron Kinner
Honored Contributor

Re: Disable keypad on laptop

Believe you want to kill the mouse touchpad and not the keypad. You should be able to do it from the Control Panel / Mouse icon. Select Hardware and then the one you want to kill and then Properties. Under the General tab there should be a line Called Device Usage which should say: Use this device(enable). If you click on the down arrow then you can choose: Do not use this device (disable) and then select OK.

You will also find that under the Mouse Touchpad properties is an option to turn off the tap equals click feature which is probably more what you want to do. That way the mouse pointing still works but you have to use the buttons to generate a click.

Ron

MarkSyder
Honored Contributor

Re: Disable keypad on laptop

Thanks Ron.Unfortunately, it shows three entries for mouse, one of which is PS2 (I assume this is the touchpad). I can disable the HID device, which is the mouse I plugged in, and I can disable the serial one, which has no effect as there isn't a serial mouse. The PS2 one does not have an option to disable.Any more ideas would be welcome.MarkPS - please excuse the absence of line breaks. I'm writing this on my RISC OS computer. I prefer RISC OS for virtually everything, but when I enter text into an HTML form like this one it doesn't register when I press the enter key.
The triumph of evil requires only that good men do nothing
Thomas Bianco
Honored Contributor

Re: Disable keypad on laptop

most laptops do use PS2 as the connection for internal touchpads/pointer-sticks. unfortunatly, there is no way to disable a PS2 mouse from device manager. check out http://support.microsoft.com/default.aspx?scid=kb;en-us;258797


there usually is a bios setting to this effect though.
There have been Innumerable people who have helped me. Of course, I've managed to piss most of them off.
MarkSyder
Honored Contributor

Re: Disable keypad on laptop

Hi everybody.

Sorry I've kept you waiting for your points -I wanted to speak to the shop first to see what they said about disabling the touchpad.

Their response was "It's got a hardware fault. Bring it in while it's still under warranty."

I'm taking their advice.

Thanks for the suggestions.

Mark
The triumph of evil requires only that good men do nothing