General
cancel
Showing results for 
Search instead for 
Did you mean: 

Display problem with SUSE linux 9.2

SOLVED
Go to solution
Thomas_190
Occasional Visitor

Display problem with SUSE linux 9.2

I installed SUSE Linux 9.2 on a Compaq Armad E500 (win 2000, ATI Rage mobility 1400 x1050)everything works up installing display. The ATI card is proberly discovered but the screen was showm as VESA 1024x 768 60 Mhz. Changig and testing diffrent screens shows only 20 % of display then two lines and nothing below. Changing Later in KDE Controllcenter gives the same effect.
Hope anyone cane giv some help.

best regards
6 REPLIES
Steven E. Protter
Exalted Contributor

Re: Display problem with SUSE linux 9.2

Sounds like the card is being mis-discovered and the wrong drivers are being used.

If this card is built in, disable it and try a different card.

Suse 9.2 is relatively recent so if this card won't work with it, the fastest fix is to ditch the card.

This can also happen as a result of a hardware failure.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
David Timms
Frequent Advisor

Re: Display problem with SUSE linux 9.2

Did you set it up for dual boot ? Does the screen / laptop still run alright under win2000 ?


Thomas_190
Occasional Visitor

Re: Display problem with SUSE linux 9.2

The screen is ok under Win2000. What do yüou mean with "set up for dual boot"
Jean-Paul Marinier_2
Occasional Visitor
Solution

Re: Display problem with SUSE linux 9.2


I had a similar problem under Suse 9.2 with an HP Omnibook 6000 laptop PC. The laptop includes an ATI Rage Mobility graphics card.

The X11 display after installing Suse was incorrect, with a large white stripe near the top of the screen.

It turned out, the Suse installation process had created a /boot/grub/menu.lst file which passed an incorrect vga= argument to the linux kernel at boot time.

Changing from "vga=0x314" to "vga=0xF00" in the menu.lst file corrected the whole problem. I did not have to change the XF86Config file at all.

See file Documentation/svga.txt in the kernel source tree for details about the vga= kernel option.

Hope it helps,

Jean-Paul

Thomas_190
Occasional Visitor

Re: Display problem with SUSE linux 9.2

It Works

Thank you Jean-Paul

best regards
Thomas_190
Occasional Visitor

Re: Display problem with SUSE linux 9.2

I changed in the the /boot/grub/menu.lst file the otion "vga=0x314" to "vga=0xF00".