General
cancel
Showing results for 
Search instead for 
Did you mean: 

Emulex drivers on linux : make build fails

Jose_129
Regular Advisor

Emulex drivers on linux : make build fails

I am trying to install drivers for my FCA`s
Both are emulex LP9002L on Linux Red hat Professional 9 with kernel 2.4.20-30.9. During install i get this:

[root@emp lpfc]# make build
Build Environment root: /usr/src/linux/linux-2.4.20-30.9
cc -D__GENKSYMS__ -D__KERNEL__=1 -I./include -I/usr/src/linux/linux-2.4.20-30.9/drivers/scsi -I/usr/src/linux/linux-2.4.20-30.9/include/scsi -I/usr/src/linux/linux-2.4.20-30.9/include -DLP6000 -D_LINUX -I./include -I/usr/src/linux/linux-2.4.20-30.9/drivers/scsi -I/usr/src/linux/linux-2.4.20-30.9/include/scsi -I/usr/src/linux/linux-2.4.20-30.9/include -E fcLINUXfcp.c > lpfc.ver1
cat lpfc.ver1 | /sbin/genksyms -k 2.2.5 > lpfc.ver
cc -Wall -O2 -fomit-frame-pointer -D__KERNEL__=1 -I./include -I/usr/src/linux/linux-2.4.20-30.9/drivers/scsi -I/usr/src/linux/linux-2.4.20-30.9/include/scsi -I/usr/src/linux/linux-2.4.20-30.9/include -DMODULE -DMODVERSIONS -include /usr/src/linux/linux-2.4.20-30.9/include/linux/modversions.h -DLP6000 -D_LINUX -I./include -I/usr/src/linux/linux-2.4.20-30.9/drivers/scsi -I/usr/src/linux/linux-2.4.20-30.9/include/scsi -I/usr/src/linux/linux-2.4.20-30.9/include -c fcLINUXfcp.c
In file included from /usr/src/linux/linux-2.4.20-30.9/include/linux/prefetch.h:13,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/list.h:6,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/wait.h:14,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/fs.h:12,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/capability.h:17,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/binfmts.h:4,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/sched.h:10,
from fcLINUXfcp.c:31:
/usr/src/linux/linux-2.4.20-30.9/include/asm/processor.h:268:1: warning: "EISA_bus" redefined
In file included from /usr/src/linux/linux-2.4.20-30.9/include/linux/modversions.h:133,
from :1:
/usr/src/linux/linux-2.4.20-30.9/include/linux/modules/i386_ksyms.ver:101:1: warning: this is the location of the previous definition
rm -f lpfc.ver1
cc -Wall -O2 -fomit-frame-pointer -D__KERNEL__=1 -I./include -I/usr/src/linux/linux-2.4.20-30.9/drivers/scsi -I/usr/src/linux/linux-2.4.20-30.9/include/scsi -I/usr/src/linux/linux-2.4.20-30.9/include -DMODULE -DMODVERSIONS -include /usr/src/linux/linux-2.4.20-30.9/include/linux/modversions.h -DLP6000 -D_LINUX -I./include -I/usr/src/linux/linux-2.4.20-30.9/drivers/scsi -I/usr/src/linux/linux-2.4.20-30.9/include/scsi -I/usr/src/linux/linux-2.4.20-30.9/include -c fcLINUXlan.c
In file included from /usr/src/linux/linux-2.4.20-30.9/include/linux/prefetch.h:13,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/list.h:6,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/wait.h:14,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/fs.h:12,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/capability.h:17,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/binfmts.h:4,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/sched.h:10,
from fcLINUXlan.c:30:
/usr/src/linux/linux-2.4.20-30.9/include/asm/processor.h:268:1: warning: "EISA_bus" redefined
In file included from /usr/src/linux/linux-2.4.20-30.9/include/linux/modversions.h:133,
from :1:
/usr/src/linux/linux-2.4.20-30.9/include/linux/modules/i386_ksyms.ver:101:1: warning: this is the location of the previous definition
rm -f lpfc.ver
cc -Wall -O2 -fomit-frame-pointer -D__KERNEL__=1 -I./include -I/usr/src/linux/linux-2.4.20-30.9/drivers/scsi -I/usr/src/linux/linux-2.4.20-30.9/include/scsi -I/usr/src/linux/linux-2.4.20-30.9/include -DMODULE -DMODVERSIONS -include /usr/src/linux/linux-2.4.20-30.9/include/linux/modversions.h -DLP6000 -D_LINUX -I./include -I/usr/src/linux/linux-2.4.20-30.9/drivers/scsi -I/usr/src/linux/linux-2.4.20-30.9/include/scsi -I/usr/src/linux/linux-2.4.20-30.9/include -c lpfc.conf.c
In file included from /usr/src/linux/linux-2.4.20-30.9/include/linux/blkdev.h:5,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/blk.h:4,
from include/fc_os.h:30,
from lpfc.conf.c:25:
/usr/src/linux/linux-2.4.20-30.9/include/linux/sched.h:6: invalid suffix on integer constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/sched.h:6: parse error before numeric constant
In file included from /usr/src/linux/linux-2.4.20-30.9/include/linux/wait.h:13,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/fs.h:12,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/capability.h:17,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/binfmts.h:4,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/sched.h:10,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/blkdev.h:5,
from /usr/src/linux/linux-2.4.20-30.9/include/linux/blk.h:4,
from include/fc_os.h:30,
from lpfc.conf.c:25:
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:60: invalid suffix on integer constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:60: parse error before numeric constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:61: invalid suffix on integer constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:61: parse error before numeric constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:62: `panic_R_ver_str' declared as function returning a function
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:68: parse error before numeric constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:68: `simple_strtoul_R_ver_str' declared as function returning a function
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:69: invalid suffix on integer constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:69: parse error before numeric constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:69: `simple_strtol_R_ver_str' declared as function returning a function
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:70: invalid suffix on integer constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:70: parse error before numeric constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:70: `simple_strtoull_R_ver_str' declared as function returning a function
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:72: invalid suffix on integer constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:72: parse error before numeric constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:73: `sprintf_R_ver_str' declared as function returning a function
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:74: invalid suffix on integer constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:74: parse error before numeric constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:74: `vsprintf_R_ver_str' declared as function returning a function
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:75: invalid suffix on integer constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:75: parse error before numeric constant
/usr/src/linux/linux-2.4.20-30.9/include/linux/kernel.h:76: `snprintf_R_ver_str' declared as function returning a function
..
.
.

/usr/src/linux-2.4.20-30.9/include/linux/netdevice.h:615: called object is not a function
In file included from /usr/src/linux-2.4.20-30.9/include/linux/pci.h:657,
from /usr/src/linux-2.4.20-30.9/drivers/scsi/scsi.h:47,
from /usr/src/linux-2.4.20-30.9/drivers/scsi/sd.h:19,
from include/fc_os.h:44,
from lpfc.conf.c:25:
/usr/src/linux-2.4.20-30.9/include/asm/pci.h: In function `pci_map_single':
/usr/src/linux-2.4.20-30.9/include/asm/pci.h:81: warning: implicit declaration of function `__out_of_line_bug_R8b0fd3c5'
make: *** [build] Error 1

Any Idea's..

Regards

Jose
Change password in way single user, beginning in multiuser way console
4 REPLIES
Jose_129
Regular Advisor

Re: Emulex drivers on linux : make build fails

Any new's

Regards,

Jose
Change password in way single user, beginning in multiuser way console
Jeroen Peereboom
Honored Contributor

Re: Emulex drivers on linux : make build fails

Jose,

not really. I searched on Google, but no definite answer.

I had compiler problems with RHAS2.1 and had to install some newer (kernel related) software .

Are you sure your kernel source is correct for the running kernel?

What version did you download from Emulex.

JP.
Jose_129
Regular Advisor

Re: Emulex drivers on linux : make build fails

I install Linux Red Hat Enterprise V3 and download driver for Enterprise y compile driver.

Regards,

Change password in way single user, beginning in multiuser way console
Jeroen Peereboom
Honored Contributor

Re: Emulex drivers on linux : make build fails

Jose,

Your questions says RH Pro 9, but your last answer shows RH AS3.

Half a year aggo I installed Emulex drivers on RH AS3U1, with kernel 2.4.21-9. The only thing I had to do was to create a symbolic link from the actual kernel source to /usr/src/linux before installing (because this directory was not present.

Maybe you can download a the newer RH AS3U1 or RHAS3U2?

Or did you already do that?

JP