Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Error Installing DBI-1.52 on HP UNIX 11v2

Pravin Baban Bhingare
Occasional Visitor

Error Installing DBI-1.52 on HP UNIX 11v2

I am trying to install DBI-1.52 on HP UNIX 11v2 with Oracle 11.1.0 . I tried to compile it with the perl 5.8.3 (/usr/bin/,/opt/perl/,/opt/perl_32,/opt/perl_64)

I am following below steps to install it .
1) cd /opt/gpsy/dbdsource/
(Ensure that the downloaded source code .tar.gz file is present in this directory)

2) gzip -dc DBI-1.52.tar.tar | tar -xvf –
3) cp –R DBI-1.52 DBI
4) cd /opt/gpsy/dbdsource/DBI

5) Perform the following:
(i) Ensure that the new Perl v5.8.3 path is present in the $PATH environment variable and that this version of Perl is now the default Perl (hence it should be defined in $PATH variable before /usr/bin)

export ORACLE_HOME=/u01/app/oracle/product/11.1.0/db_1
export ORACLE_BASE=/u01/app/oracle
export PATH=/usr/bin:/opt/gpsy/dbdsource:$ORACLE_HOME:$ORACLE_BASE:$PATH


(ii) In /opt/gpsy/dbdsource/DBI/Makefile.PL add the below parameters after COMPRESS => 'gzip -v9', SUFFIX => 'gz',
},

INST_BIN => "/opt/gpsy/dbdsource/DBI",
INST_EXE => "/opt/gpsy/dbdsource/DBI",
INST_LIB => "/opt/gpsy/dbdsource/DBI",
INST_ARCHLIB => "/opt/gpsy/dbdsource/DBI",
INST_SCRIPT => "/opt/gpsy/dbdsource/DBI",
INST_MAN1DIR => "/opt/gpsy/dbdsource/DBI",
INST_MAN3DIR => "/opt/gpsy/dbdsource/DBI",

(iii) Run:

perl Makefile.PL

Change the macros in the Makefile

From
PERLPREFIX = /opt/perl_32
SITEPREFIX = /opt/perl_32
VENDORPREFIX =/opt/perl_32

To
PERLPREFIX = /opt/gpsy/dbdsource/DBI
SITEPREFIX = /opt/gpsy/dbdsource/DBI
VENDORPREFIX = /opt/gpsy/dbdsource/DBI

(iv) Run:
make

(v) Run:
make test

(vi) make install


I am getting following error at step (iv) Run make .


running Mkbootstrap for DBI ()
chmod 644 DBI.bs
rm -f /opt/gpsy/dbds/DBI/auto/DBI/DBI.so
LD_RUN_PATH="" /usr/bin/ld -b +vnocompatwarnings -L/usr/lib/hpux32 DBI.o -o /opt/gpsy/dbds/DBI/auto/DBI/DBI.so
chmod 755 /opt/gpsy/dbds/DBI/auto/DBI/DBI.so
cp DBI.bs /opt/gpsy/dbds/DBI/auto/DBI/DBI.bs
chmod 644 /opt/gpsy/dbds/DBI/auto/DBI/DBI.bs
/opt/perl_32/bin/perl "-I/opt/gpsy/dbds/DBI" "-I/opt/gpsy/dbds/DBI" dbiprof.PL dbiprof
Extracted dbiprof from dbiprof.PL with variable substitutions.
cp dbiprof /opt/gpsy/dbds/DBI/dbiprof
cp: cannot access dbiprof: No such file or directory
*** Error exit code 1


Please hlpe me in resolving this issue.
3 REPLIES
Fabio Ettore
Honored Contributor

Re: Error Installing DBI-1.52 on HP UNIX 11v2

Hi,

considering last excerpt of the error:

.....
cp dbiprof /opt/gpsy/dbds/DBI/dbiprof
cp: cannot access dbiprof: No such file or directory
*** Error exit code 1

Please provide the following outputs:

ll dbiprof
ll /opt/gpsy/dbds/DBI/dbiprof

Best regards,
Fabio
WISH? IMPROVEMENT!
Pravin Baban Bhingare
Occasional Visitor

Re: Error Installing DBI-1.52 on HP UNIX 11v2

Hi Fabio ,

Thanks for reply .
can you please provide me detail steps .

Thanks
Regards
Pravin Bhingare
Fabio Ettore
Honored Contributor

Re: Error Installing DBI-1.52 on HP UNIX 11v2

Hi,

I provided you the detailed steps, I asked for providing the following outputs:

ll dbiprof
ll /opt/gpsy/dbds/DBI/dbiprof

Obviuosuly you have to do that under /opt/gpsy/dbdsource/.

Best regards,
Fabio
WISH? IMPROVEMENT!