Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Ethernet Failover configuration

SOLVED
Go to solution
binil
Advisor

Ethernet Failover configuration

Hi all,
How can we configure the ethernet failover in RedHat Advanced server 2.1 with out having cluster?

* System- Compaq ML370 server
* OS - Linux RedHat Advanced server 2.1
* Ethernet Cards - 2 No. of 1Gig cards.

Thnaks in Advance !
Binil

Binil.P.Narayanan
4 REPLIES
Kodjo Agbenu
Honored Contributor
Solution

Re: Ethernet Failover configuration

Hi,

First, you must update the ethernet adapter driver with bcm5700 provided by hp (www.hp.com/linux => drivers).

Then, make sure that the proper driver is in use in /etc/modules.conf (alias ethX bcm5700).

Stop networking and remove the previously used module :

/etc/init.d/network stop
rmmod tg3 (or bcm5700)

Back-up your network configuration files :

cd /etc/sysconfig/network-scripts
mkdir /tmp/network-sav
cp -p ifcfg-* /tmp/network-sav


Edit the configuration files :

ifcfg-bond0 :

IPADDR=...
NETMASK=...
NETWORK=...
BROADCAST=...
ONBOOT=yes
BOOTPROTO=none
USERCTL=no

ifcfg-eth0 and ifcfg-eth1 :

USERCTL=no
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none


Edit /etc/modules.conf :

alias bond0 bonding


For other bonding driver options, type :

modinfo bonding


Start the network :

/etc/init.d/network start


Good luck.

Kodjo
Learn and explain...
binil
Advisor

Re: Ethernet Failover configuration

Hi Kodjo,
Thnak you !!
I need to test it. Any way I will Let you know the result.

Cheers /Thanks
Binil
Binil.P.Narayanan
binil
Advisor

Re: Ethernet Failover configuration

Hi Kodjo,

I tried the opton by using a PC. But facing some problems.
____________________________________________
*********************************************
I used two Intel pro/100 cards to configure ethernet fail over. The steps done are:

1. took the backup all configuration file

2. Configired both cards.
Then the entries for those cards in /etc/modules.conf were :
alias eth0 e100
alias eth1 e100

3. Stopped the network (/etc/init.d/network stop)
and run command,
rmmod e100

4. edited /etc/sysconfig/network-scriptss/ifcfg-eth0
The exact entries are:
DEVICE=eth0
ONBOOT=yes
MASTER=bond0
SLAVE=yes
BOOTPROTO=none
TYPE=Ethernet
USERCTL=no

5. edited /etc/sysconfig/network-scripts/ifcfg-eth1
same entries like above ,only diff is DEVICE=eth1

6. Edited /etc/sysconfig/network-scripts/ifcfg-bond0
The exact entries are:
ONBOOT=yes
BOOTPROTO=none
IPADDR=172.20.5.5
NETMASK=255.255.0.0
GATEWAY=172.20.1.1
TYPE=Ethernet
USERCTL=no
NETWORK=172.20.0.0
BROADCAST=172.20.255.255
PEERDNS=no

7.Added entry in /etc/modules.conf
alias bond0 bonding

8. Started the vetwork (/etc/init.d/network start)
But giving error and not starting the network service,
The mesages while starting the network service,

Setting network parameter [ok]

Bringing up interface lo [ok]

Bringing up interface bond0 :Usage :Grep [OPTION]--PATTERN [FILE]---
Try 'grep --help' for more information
Failed to Bring up.
Not enough of information : "dev" argument is required
Bringing up interface eth0 [ok]
Bringing up interface eth1 [ok]
_____________________________________________
*********************************************
So what could be the mistake I did...
Please advice ..


Thanks in advance..
Binil







Binil.P.Narayanan
binil
Advisor

Re: Ethernet Failover configuration

Hi,

When I added the entry,


DEVICE=bond0

in the file /etc/sysconfig/network-scripts/ifcfg-bond0 ,it is found working!

But if we keep only one connection (To any of the cards) 50 % package drop is happening. If both are connected 0%. Why it is so?

Any way thank you very much.

Cheers
Binil
Binil.P.Narayanan