cancel
Showing results for 
Search instead for 
Did you mean: 

Ethernet

Gabriele Mori
Occasional Advisor

Ethernet

On my dx2000 the ethernet causes an application block, the application doesn't work and it's impossible to close it, and the restart it's impossible too.
I think an hardware problem on ethernet/motherboard.

What do you think about this?

TIA
14 REPLIES
Ronald Postma
Honored Contributor

Re: Ethernet

Hi Babrele,
We need some more info:

Why do you think it is the ethernet? does your system has any network problems to?

What program hangs?

What windows version do you run?

Try to disabel the neworkcard in devicemanager, restart the system, does the problem still occour? (how to get there depens on you OS, 2000 and above you can rightclick my computer, choose management and then select devicemanger)

Do you have a clean windows isntallation? No ohter programs installed?

Did you change any hardware? or installed any software before the problem accoured, or did the program never worked after installation.

Have a nice day,
HTH, Ronald
The logic of Microsoft: "Press START to shut down the pc"
Gabriele Mori
Occasional Advisor

Re: Ethernet

The O.s. is Xp Sp2

The system are not clean, but the antivirus said "no virus found".

More programs hangs (internet explorer, word, excel) when the user works in lan, if the user works in local nothing programs hangs.

I haven't installed or remove any hardware, because the pc is under warranty.

TIA
Ivan Ferreira
Honored Contributor

Re: Ethernet

This behaviour may be caused by an undetected trojan/spyware/virus.

When connected to the network, from the command prompt, use the command:

netstat


Compare the output with another computer, that is not having the problem.

If you see too many connections, specially to unknown sites, then the computer may be having a program that tries to do a DOS attack (or something similar).
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Jon Finley
Honored Contributor

Re: Ethernet

If this is caused by spyware, try downloading and installing SpySweeper
http://www.spysweeper.org

It's a free 30 day trial that is fully functional. Uninstall it afterwards, or buy it if you like it.

Jon
"Do or do not. There is no try!" - Yoda
Ronald Postma
Honored Contributor

Re: Ethernet

Hi Gabriele,
If you want to test if it is a hardware problem you can temparary built in another HD if you have one (remove old one), install a clean XPSP2 on it and see what happends.
If everything works fine, it is a software problem or bad HD.

PS. jumper HD as Cabel Select)

Futher if you go to www.microsoft.com/downloads you can install the MS antispyware beta, it is prety good finds more then almost every other program (Do not know any free program that is better)

You can also download Hijackthis and post a log, then we can see if there are any strange processes running.
http://www.merijn.org/files/hijackthis.zip

Have a nice day,
HTH, Ronald
The logic of Microsoft: "Press START to shut down the pc"
Gabriele Mori
Occasional Advisor

Re: Ethernet

I have repleaced the motherboard (with the ethernet), but the problem persist....

I have seen with hijackthis, but there are not problem, it's only regular value on the registry...

The last application hang was Outlook, the user click on "Sent Item" and the application hang...

I have seen with "Netstat" but the connection are only the exchange connection, domain controller connection and proxy server connection
Ken wanderer
Trusted Contributor

Re: Ethernet

Could be a bad cable, bad port on the hub or even bad current. Do you have a surge suppressor?
Work Smarter Not Harder
Gabriele Mori
Occasional Advisor

Re: Ethernet

The cable was changed three week ago...

I don't have a surge suppressor.

Now i will change the port in the hub.
Michael Dillman
Valued Contributor

Re: Ethernet

You might try going into device manager. Uninstall the LAN card and then right click and Scan For Changes. Let windows readd the card. It often will fix TCP/Network Card issues.
If at first you don't succeed, you must be installing Windows
Gabriele Mori
Occasional Advisor

Re: Ethernet

The problem persist... :-(

I'have reinstalled the O.s. but 2 days ago, the problem was reappear...
I have seen with "Netstat" and there were 2 connection to external Ip in the port 80, and the user doesn't surf...

With Hijackthis there were't any strange processes running
Ivan Ferreira
Honored Contributor

Re: Ethernet

When you have the problem:

The network is still available? Can you ping the server?

Aren't you getting a duplicate IP address that may cause this hung?

If you use ping from the server to the client, and use arp -a, do you see the correct MAC address?

Can you run ftp to the server? What is the transfer rate?

Before the problem, what is the output of netstat -s?

After the problem, what is the output of netstat -s?
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Gabriele Mori
Occasional Advisor

Re: Ethernet

The network is still available? Can you ping the server?

- The network is stilla available, but in the tray the icon's network is disabled (with the red cross)

Aren't you getting a duplicate IP address that may cause this hung?

- The ip is still univocal

If you use ping from the server to the client, and use arp -a, do you see the correct MAC address?

- I will try

Can you run ftp to the server? What is the transfer rate?

- i can't

Before the problem, what is the output of netstat -s?

- i will try

After the problem, what is the output of netstat -s?

- i will try
Ivan Ferreira
Honored Contributor

Re: Ethernet

You should also consider:

- A bad power supply may damage the components.

- Electrostatical/magnetic/network noise, consider moving the computer to another location where the problem is not presented.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Gabriele Mori
Occasional Advisor

Re: Ethernet

If is a bad power supply the computer doesn't work at any time, in this case the problem happen at random....