Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

FC3 install problem on pavilion 4535

check hung
Advisor

FC3 install problem on pavilion 4535

I tried to upgrade from RH8 to FC3 and it failed. I was able to do a clean re-install of RH8. When I tried to do a clean install of FC3 it hanged on first reboot config process. I saw the LICENSE agreement screen. I clicked the "agreed" and "next" buttons , I then saw a display of scrambled screen ( with color streaks) twice and the screen went blank. The system seemed to hang.

There was a message when it was booting up:
PCI : cannot allocate resource region 4 of device 0000:00:1f.1

I think the Xconfig is ok because I saw the License agreement display and the small windows when it was starting sshd..... etc.
What can I try? TIA
I swear I didn't do anything but last night when I turned on the machine it continued with the set up process and rebooted to display the login screen. When I logged in it displays the gnome desktop. When I tried the application drop down menu I got the "color streaks" display again.
During the install FC3 detected the intel 810 video card. Does it mean it should already have the driver to handle the display?
------------
8 REPLIES
Steven E. Protter
Exalted Contributor

Re: FC3 install problem on pavilion 4535

The installation should have worked. In truth the hardware for Pavillion systems is not very good and although it seems counterintuitive, support for some hardware in FC was dropped as new releases came out.

I would suggest the following:

Perhaps FC4 or FC2.

I found FC1 to be extremely stable as well, but is also is quite old. FC4 did not work out well when I tested it.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Gopi Sekar
Honored Contributor

Re: FC3 install problem on pavilion 4535


I would suggest you to try FC4 on the same hardware. The problem could be either display hardware or the display driver of FC3.

If the system works fine with RH8 then it is more likely the issue of FC3. Try FC4 which is latest and should have better hardware support.

Regards,
Gopi
Never Never Never Giveup
check hung
Advisor

Re: FC3 install problem on pavilion 4535

I wonder how much memory is used when FC3 starts up in gnome (desktop config). My box has 192m. Can I get into the single user mode during boot or from the login screen? thanks
Gopi Sekar
Honored Contributor

Re: FC3 install problem on pavilion 4535


Even if it is less RAM it should work fine (although very slowly due to memory swapping).I believe the recommended memory for FC2 and above is 256 MB.

If you don't want to go in to GUI mode, then when the system boots up and waits at the GRUB prompt, press 'e' to edit the selected grub entry and at the end of the line add the letter '3' (without quotes), FC3 will boot in to text only mode from where you can work.

Regards,
Gopi
Never Never Never Giveup
check hung
Advisor

Re: FC3 install problem on pavilion 4535

Running in text mode (level 3) I did a init 5 , select gnome from the
"session" menu of the login screen, the gnome desktop seems to be
running ok. I then changed the inittab to level 5 and rebooted. I got
the same hanged blank screen.
Following is the /etc/X11/xorg.conf file. Anything looks suspicious?
------------------------
# XFree86 4 configuration created by pyxf86config



Section "ServerLayout"

Identifier "Default Layout"

Screen 0 "Screen0" 0 0

InputDevice "Mouse0" "CorePointer"

InputDevice "Keyboard0" "CoreKeyboard"

EndSection



Section "Files"

# RgbPath is the location of the RGB database. Note, this is the name of the

# file minus the extension (like ".txt" or ".db"). There is normally

# no need to change the default.



# Multiple FontPath entries are allowed (they are concatenated together)

# By default, Red Hat 6.0 and later now use a font server independent of

# the X server to render fonts.



RgbPath "/usr/X11R6/lib/X11/rgb"

FontPath "unix/:7100"

EndSection



Section "Module"

Load "dbe"

Load "extmod"

Load "fbdevhw"

Load "glx"

Load "record"

Load "freetype"

Load "type1"

Load "dri"

EndSection



Section "InputDevice"

# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))

# Option "Xleds" "1 2 3"



# To disable the XKEYBOARD extension, uncomment XkbDisable.

# Option "XkbDisable"



# To customise the XKB settings to suit your keyboard, modify the

# lines below (which are the defaults). For example, for a non-U.S.

# keyboard, you will probably want to use:

# Option "XkbModel" "pc102"

# If you have a US Microsoft Natural keyboard, you can use:

# Option "XkbModel" "microsoft"

#

# Then to change the language, change the Layout setting.

# For example, a german layout can be obtained with:

# Option "XkbLayout" "de"

# or:

# Option "XkbLayout" "de"

# Option "XkbVariant" "nodeadkeys"

#

# If you'd like to switch the positions of your capslock and

# control keys, use:

# Option "XkbOptions" "ctrl:swapcaps"

# Or if you just want both to be control, use:

# Option "XkbOptions" "ctrl:nocaps"

#

Identifier "Keyboard0"

Driver "kbd"

Option "XkbModel" "pc105"

Option "XkbLayout" "us"

EndSection



Section "InputDevice"

Identifier "Mouse0"

Driver "mouse"

Option "Protocol" "IMPS/2"

Option "Device" "/dev/input/mice"

Option "ZAxisMapping" "4 5"

Option "Emulate3Buttons" "yes"

EndSection



Section "Monitor"

Identifier "Monitor0"

VendorName "Monitor Vendor"

ModelName "ViewSonic E70f+"

DisplaySize 320 240

HorizSync 30.0 - 72.0

VertRefresh 50.0 - 150.0

Option "dpms"

EndSection



Section "Device"

Identifier "Videocard0"

Driver "i810"

VendorName "Videocard vendor"

BoardName "Intel 810"

EndSection



Section "Screen"

Identifier "Screen0"

Device "Videocard0"

Monitor "Monitor0"

DefaultDepth 16

SubSection "Display"

Viewport 0 0

Depth 16

Modes "800x600" "640x480"

EndSubSection

EndSection



Section "DRI"

Group 0

Mode 0666

EndSection



-----------------------------
Gopi Sekar
Honored Contributor

Re: FC3 install problem on pavilion 4535


when you are getting hanged blank screen, try rebooting the system back to init 3 and check the /var/log/XFree86.*log files, these should have the reason why it is failed to start.

Paste those files and let us take a look at it.

One another common reason where we see this kind of problem is if the xfs service is not running. Ensure you have xfs service enabled and running at startup during init level 5.

Regards,
Gopi
Never Never Never Giveup
check hung
Advisor

Re: FC3 install problem on pavilion 4535

I might have tumbled into a workaround ( if I can set the default session):

On the gui login screen when I hit the "session" button there are three choices:
1. GNOME
2. Default System Session
3. Failsafe Terminal

If I choose GNOME the session will be fine but hangs if I choose 2. When the screen is up the choice is automatically set to 2. How can I set it to 1. or have 2. point to GNOME? I looked at /etc/X11/gdm.conf but it doesn't seem to be set there.

Anyhow attached is the Xorg.0.log file. Naturally nothing is wrong as I can see:
check hung
Advisor

Re: FC3 install problem on pavilion 4535

Problem solved.
Having noticed that boot on level 5 displays progress windows while init 5 only shows text status( xxxxxxxxxxxx [ok]). Looking around I found the file /etc/sysconfig/init has an option " boot in graphic mode", set it to "no". The system boots up ok.
Thanks all for your input.