General

Failed to start Agentless Management Service daemon rhel 7.5

 
manu7cabre87
Occasional Contributor

Failed to start Agentless Management Service daemon rhel 7.5

hello, 

I have a problem when running amsd-1.2.0-2657.49.rhel7.x86_64 with a DL380 Server and Red Hat 7.5 

● amsd.service - Agentless Management Service daemon
Loaded: loaded (/usr/lib/systemd/system/amsd.service; enabled; vendor preset: disabled)
Active: failed (Result: start-limit) since Mon 2020-01-06 21:08:37 CST; 4s ago
Process: 20867 ExecStart=/sbin/amsd -f $AMSD_OPTIONS (code=dumped, signal=SEGV)
Main PID: 20867 (code=dumped, signal=SEGV)

Jan 06 21:08:36 MEX-CPF1-MCC100-2 systemd[1]: Failed to start Agentless Management Service daemon.
Jan 06 21:08:36 MEX-CPF1-MCC100-2 systemd[1]: Unit amsd.service entered failed state.
Jan 06 21:08:36 MEX-CPF1-MCC100-2 systemd[1]: amsd.service failed.
Jan 06 21:08:37 MEX-CPF1-MCC100-2 systemd[1]: amsd.service holdoff time over, scheduling restart.
Jan 06 21:08:37 MEX-CPF1-MCC100-2 systemd[1]: start request repeated too quickly for amsd.service
Jan 06 21:08:37 MEX-CPF1-MCC100-2 systemd[1]: Failed to start Agentless Management Service daemon.
Jan 06 21:08:37 MEX-CPF1-MCC100-2 systemd[1]: Unit amsd.service entered failed state.
Jan 06 21:08:37 MEX-CPF1-MCC100-2 systemd[1]: amsd.service failed.

1 REPLY 1
Tech_Aniket
HPE Pro

Re: Failed to start Agentless Management Service daemon rhel 7.5

Hello,

 

Thank you for posting your query on HPE Community.

Looking at the AMS version(1.2.0-2657.49.rhel7.x86_64), i believe this is a Gen10 server.

I would request you to try uninstall the previous version of AMS installed and try intalling the latest version --

Link -->  https://support.hpe.com/hpsc/swd/public/detail?swItemId=MTX_ab076eac860741fe8f98b27b21#tab-history

 

**Important Prerequisites:

  • amsd only supported on HPE Gen10 Servers.

  • amsd provides information to the iLO 5 service providing SNMP support.

  • Requirements:

    • Minimum iLO 5 Firmware Version = 1.1

    • Minimum supported OS Versions = Red Hat Enterprise Linux 7.3 Errata 3.10.0.514.6.1

You can check the status of the AMS using the following commands -

Verifying AMS status: SUSE and Red Hat Enterprise Linux

  1. To verify that AMS is installed, enter the following command: rpm –qi hp-ams.

  2. To verify that AMS is running, enter the following command: service hp-ams status.

You can refer to the link shared below - 

Link --> https://support.hpe.com/hpsc/doc/public/display?docId=emr_na-a00026111en_us&docLocale=en_US

 

Regards,

Aniket Chauhan

I am an HPE Employee

Accept or Kudo