cancel
Showing results for 
Search instead for 
Did you mean: 

Fedora help

Felipe Rodriguez_1
Frequent Advisor

Fedora help

I installed Fedora 4 on my laptop as a dual boot. I had to do the install in text mode because my screen would come up white.

The install seemed to go well; I have the dual boot prompt and windows starts and runs ok.
But when Fedora boots, I get the white screen again.

There is an option that says to press "I" for interactive boot. I tried "i", "i" followed by Enter, "I", etc., but it just goes through the motions and brings up the white screen.

Oh, there is an initial mouse pointer ("X") that comes up briefly, then goes away.

How do I fix that?

Also, the dual boot defaults to Fedora; how do I change it to windows?
22 REPLIES
Ivan Ferreira
Honored Contributor

Re: Fedora help

When you get the boot menu (GRUB), select to boot linux but do not press ENTER.

Press the followin keys:

Any key to stop the autoboot
a
3
ENTER
b

You will start in rulevel 3, so X won't be started. You can run system-config-display --reconfig.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Felipe Rodriguez_1
Frequent Advisor

Re: Fedora help

OK, followed these instructions but nothing changed.

I stopped the auto boot.
While at the boot menu, with Fedora selected, I pressed a. Nothing hapened.

Then I pressed 3, still nothing hapenned.

I pressend ENTER and the boot process begins. I immediately press b.

The process continues as before. I get to the Welcome step and it again says to press 'I' to enter interactive startup.

No matter what I do from this point, I get the white screen.
Felipe Rodriguez_1
Frequent Advisor

Re: Fedora help

Well, I resorted to the good ol' CTL+C to interrupt the boot. I got the interactive startup.

Problem is it asks a lot of questions on starting processes and I have no clue as to which I should or should not start. I tried replying n to all and got to a screen that says

"I could not start the X server due to some internal error. Please contact sys admin to diagnose. In the meantime this display will be disabled. Please restart gdm when the problem is correcte."

Felipe Rodriguez_1
Frequent Advisor

Re: Fedora help

I tried several combinations and by relying Y to the "first boot" prompt I was able to get a login:
However, the user I configured 'does not exist' and the root password is incorrect. I guess I'm going to have to re-install and see how that goes.
Andrew Bruce
Valued Contributor

Re: Fedora help

Note, where I suggest you type something in, do *not* include the quote marks (unless I specifically say to do so!).

First off let's get booted:

When you power up the laptop, after the BIOS start up, you should get the GRUB window that says something about booting linux (Fedora) in 10 seconds, press a key to interrupt.

Press the any key if your keyboard has one (bad joke).

Just interrupt the GRUB boot by pressing a key. You should now have a GRUB display showing your dual boot options (and no count down timer - if there is a count down time, press a key again (any key will do!)).

Next, you can alter the boot options for this boot.

If the root password is wrong, you can boot into single user mode and reset the password:

Making sure the splash screen still says something about GRUB, make sure the Fedora option is highlighted.

There are some instructions at the bottom that say:

"Press enter to boot the selected OS, 'e' to edit the commands before booting, 'a' to modify kernel arguments before booting, or 'c' for a command-line."

Press 'a'

The screen should now change to show you a line which may say something like:

grub append> ro root=label=/ rhgb .....

At the end of the line, add the word 'single'

This tells the boot process that you want to boot the laptop into single user mode.

Next, hit return.

Your system *should* boot up straight into a command prompt.

From here you can set the root password:

sh-3.00# passwd

Enter the new password, then re-enter it to confirm.

A word of warning: Bear in mind that your original password may have been set 'incorrectly' if your keyboard layout is not the same as that which the system thought it was!

Avoid using characters that may change depending on your keymap For example, '@' and '"' characters are often swapped about. As are '£' (UK Pound sign) and '#').

This will sort out the root password.

Next, you can edit your boot config so that Windows is the default boot option:

(Assuming you know how to use the 'vi' editor)

sh-3.00# vi /boot/grub/grub.conf

You will see a line that reads something like:

default=0

This tells the system which menu option is the default one to boot from.

Further below in the file, you will see at least two lines that begin:

title

These are the start of your menu options.

I'll assume that they are something like:

title Fedora Core 4 ...
...

title Windows ...
...

Everything in GRUB starts counting from zero (not one). So the first option (Fedora) is option zero. The second option (Windows) is option one.

Change the:

default=0

to read:

default=1

*IF* Windows is the second option. If windows is the first option, then I guess the defaults I've written above would be the other way around!

Next, you need to sort out X.

Currently, your laptop is in single user mode and you won't be able to run any X config type apps.

Execute:

sh-3.00# init 3

This will tell the system to change from single user mode to run level three (multi-user, non-graphical).

You will need to log in (as root).

Login using your new password and execute:

# system-config-display --reconfig

If all goes well, you should have a graphical gui start up which allows you to configure your X11 display.

For more info on how X11 works, google about and you should find lots of material.

Top-tip: Google has a linux specific search engine:

http://www.google.com/linux

Go from there.

Regards,

Andy Bruce
I Love it when a plan comes together!
Felipe Rodriguez_1
Frequent Advisor

Re: Fedora help

I'm reloading as I type this, but will keep this in mind if I run into trouble.

I can remember that the only option at the grub menu was to enter 'p' to enter a password for security something or other. No 'a' or anything else.

We will see in a while.

Thanks.
Andrew Bruce
Valued Contributor

Re: Fedora help

Ah!

Sounds like you maybe set up a password for the GRUB loader which stops ner-do-well individuals from trying to access your system in the way I just described!

Could it be that the password that you thought you'd set up for root was actually the GRUB loader password?

Anyway, if this happens again, enter the password, then you should be able to do what I described earlier!

Any problems, give us a shout!

Regards,

Andy Bruce

ps Some points wouldn't go a miss! ;-)
I Love it when a plan comes together!
Felipe Rodriguez_1
Frequent Advisor

Re: Fedora help

I tried the password at that prompt but it did not work either.
I'll post back as soon as I'm done with the install.
Felipe Rodriguez_1
Frequent Advisor

Re: Fedora help

I'm at the 'system-config-display--reconfig' part.

It says "command not found"

I tried a space after ...-display as in

'system-config-display --reconfig'

but that did not work, all I get is the help text. What am I doing wrong?
Andrew Bruce
Valued Contributor

Re: Fedora help

You want to use:

# system-config-display --reconfig

white space---------------^

(Hopefully my arrow lines up correctly!)

i.e. two 'words'

1. system-config-display
2. --reconfig

with an empty space between the '...lay' and the '--rec...'

(IIRC -- (double minus) is for defining options according to a posix compliancy thing, and you see it a lot in Linux. Most folk are more accustomed to just seeing single minus signs - confusing! :-)

Regards,

Andy Bruce
I Love it when a plan comes together!
Felipe Rodriguez_1
Frequent Advisor

Re: Fedora help

OK, the command ran, but I still get the mouse pointer(X) briefly, then a totally white screen, which by the way is smaller than the available space on my monitor. Grrrrr!
Andrew Bruce
Valued Contributor

Re: Fedora help

Ok.

Next step:

Reboot into runlevel 3

(do what I described for single user mode, but replace the 'single' with the number '3').

Manually edit the X11 config file:

vi /etc/X11/xorg.conf

and set up a very basic X-Display configuration (e.g. 640x480 8 bit colour).

Once you have done this, execute:

# init 5

which will launch the graphical mode.

If this *still* doesn't work, you can flip between graphical and text mode using the virtual consoles:

ctr-alt-F1 to ctr-alt-F6 should all give you text consoles, while ctr-alt-F7 will return you to the graphical screen.

In fact, as I think about it, no need to reboot!

Boot up.

Once the screen messes up, hit ctr-alt-F1 and you *should* get a text screen.

Execute:

# init 3

to switch off the X display

edit the xorg.conf file

Execute:

# init 5

to get the X display up again, and see if it is showing enything.

This way, you can flip between init 3 and init 5 to make adjustments without rebooting.

As for the changes to your xorg.conf file, I can't comment without knowing what your hardware is.

One other thing you can do, is look to see if Fedora has loaded a driver for your graphics adapter:

Execute:

# lsmod

and you will be shown a list of all the kernel modules (drivers) that are currently loaded.

Hopefully, you will see something that is relevent to your hardware (e.g. radeon, or nvidia (sometimes also 'nv', etc.).

Regards,

Andy Bruce
I Love it when a plan comes together!
Felipe Rodriguez_1
Frequent Advisor

Re: Fedora help

"...and set up a very basic X-Display configuration (e.g. 640x480 8 bit colour)"

How do I do that? There is no similar entry in that file now that I can use as a guide. here is what it says:

#XFree86 4 configuration created by pyxf86config

Section "ServerLayout"
Identifier "Default Layout"
Screen 0 "Screen0" 0 0
InputDevice "Mouse0" "CorePointer"
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Synaptics" "AlwaysCore"
EndSection

Section "Files"
# six lines of comments.

RgbPath "/usr/X11R6/lib/X11/rgb"
FontPath "unix/:7100"
EndSection

Section "Module"
"/etc/X11/xorg.conf" 130L, 3322C




Felipe Rodriguez_1
Frequent Advisor

Re: Fedora help

In the hopes that you can help me make this work, here is some info on my hdw.

Toshiba Satellite 1805-S207

Graphics/Video:
Active Matrix disp, supports up to 16M colors at 1024 x 768
Trident Cybr ALADDiN-T integrated controller 16MB external UMA VRAM
3D Graph Accel, AGP bus support 2D graph accel, BitBLT hdw, HDW cursor, Direct Draw support.
External color support:
Lists ranges from 640x480 to 1600x1200

My Windows 2003 Server OS lists a Standard VGA Display
Ivan Ferreira
Honored Contributor

Re: Fedora help

Run system-config-display. If you have problems, or if you cannot find the exact model for your video adapter and monitor, try the most similar one, or a generic monitor that supports the resolution of your display.

To configure a "generic" video adapter driver, run:

system-config-display --reconfig --set-driver=vesa

The "vesa" works with all video adapters, but lacks of specific features.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Andrew Bruce
Valued Contributor

Re: Fedora help

Have you had a look at any xorg documentation?

Try http://www.linuxpackages.net/howto/slackfiles/books/slackware-basics/html/x11.html

for a start.

The critical bits of your xorg.conf (for display) will begin with something like:

Section "Device"

EndSection

and

Section "Screen"

EndSection

Obviously, you'll need to make sure the display driver stuff is appropriate for your hardware.

Likewise, the display resolution stuff is where you can tell the system what resolution and colour depth should be used.

I just did a bit of searching on your video card and found the following example of an xorg.conf file:

http://rf.com.br/files/Toshiba_1805-S254_XF86Config-4.txt

Copy the appropriate sections into your display and device definitaions and see if it helps.

Don't forget to back up your current config!

I also found a web page from someone who has installed Redhat 7.2 on the same laptop model as yours:

http://home.comcast.net/~steven.fricke/toshiba/

There will be stuff there that is applicable to your set up (they're using XFree86 as opposed to xorg, but I believe the configuration files are pretty much the same...)

Good luck,

Andy Bruce
I Love it when a plan comes together!
Felipe Rodriguez_1
Frequent Advisor

Re: Fedora help

I tried the options in the sample files and the only progress I made was to extend the display area, but it is still all white.

With the "=vesa" option I get a somewhat part-legible screen with the words

"In Touch with Tomorrow"
"TOSHIBA"

across the top, but not much else. I can however toggle between text and graphics mode, which I couldn't do with the previous options.

Frustration starting to set in...
Ivan Ferreira
Honored Contributor

Re: Fedora help

Try again with the vesa driver, but a different monitor model. The monitor has influence in the resolution that can be displayed. After you set the driver-vesa, run system-config-display again without options to change the monitor type.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Felipe Rodriguez_1
Frequent Advisor

Re: Fedora help

What options are those?
Felipe Rodriguez_1
Frequent Advisor

Re: Fedora help

The reason I have for working on a Linux system is to practice generic UNIX stuff.

Though it would be nice to have the X environment, I'm thinking that for now I'm happy to have a command line. I'm practicing vi on the grub file for the X stuff, more for the sake of practicing vi than for the X.

I already screwed up the grub file by changing thr "root (hda0,5)" to "root (hda0,3)" thinking this was refering to the run level. I want to boot straight to the command line.
I figured out how to fix it on my own.

Thanks for all your help guys!
Felipe Rodriguez_1
Frequent Advisor

Re: Fedora help

FYI.

I found there is a bug reported in Bugzilla. The bug is in the file "libvgahw.a" for FC4. The fix is to replace this file with the one from FC3.
LCastro
Occasional Visitor

Re: Fedora help

Bruce,
Thanks for your help. It got me out of my predicament too; I had changed the settings in my gnome login display, and when it rebooted it would appear to get to the login screen for the xwindows/gnome, yet I would only have a white X as cursor, and nothing would happen.