Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

File::Glob Error

GPS
Advisor

File::Glob Error

Greetings:

My system is HP-B2000, HP-11.11 installed with mySQL(version mysql-standard-5.0.18-hpux11.11-hppa2.0w-64bit) and 64-bit PERL (version 5.8.7)

The generic PERL function works.

When I try to install mySQL DBI on PERL. I have following error which puzzled me.

:make
Can't locate loadable object for module File::Glob in @INC (@INC contains: /usr/local/lib/perl5/5.8.7/PA-RISC2.0 /usr/local/lib/perl5/5.8.7 /usr/local/lib/perl5/site_perl/5.8.7/PA-RISC2.0 /usr/local/lib/perl5/site_perl/5.8.7 /usr/local/lib/perl5/site_perl .) at /usr/local/lib/perl5/5.8.7/ExtUtils/Command.pm line 57
Compilation failed in require at /usr/local/lib/perl5/5.8.7/ExtUtils/Command.pm line 57.
BEGIN failed--compilation aborted at /usr/local/lib/perl5/5.8.7/ExtUtils/Command.pm line 57.
Compilation failed in require.
BEGIN failed--compilation aborted.
*** Error exit code 2

Stop.
===============================================

Any clue?

Thanks a lot
3 REPLIES
IT_2007
Honored Contributor

Re: File::Glob Error

Do you have perl5 installed and pointed to correct path?

>>Compilation failed in require at /usr/local/lib/perl5/5.8.7/ExtUtils/Command.pm line 57.
<<
GPS
Advisor

Re: File::Glob Error

I do have PERL 5.8.7 installed and I can launch basic PERL calls.

zcary0q6:root> perl -V
Summary of my perl5 (revision 5 version 8 subversion 7) configuration:
Platform:
osname=hpux, osvers=11.11, archname=PA-RISC2.0
uname='hp-ux hades b.11.11 u 9000800 1335053341 unlimited-user license '
config_args='-d -e -Dcc=gcc -Dprefix=/usr/local useposix=true'
hint=recommended, useposix=true, d_sigaction=define
usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
use64bitint=undef use64bitall=undef uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler:
cc='gcc', ccflags ='-D_HPUX_SOURCE -fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE',
optimize='-O2',
cppflags='-D__STDC_EXT__ -D_HPUX_SOURCE -D_HPUX_SOURCE -fno-strict-aliasing -pipe -I/usr/local/include'
ccversion='', gccversion='4.0.2', gccosandvers=''
intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=4321
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=4
alignbytes=8, prototype=define
Linker and Libraries:
ld='/usr/bin/ld', ldflags =' -L/usr/local/lib -L/opt/local/lib'
libpth=/usr/local/lib /opt/local/lib /lib /usr/lib /usr/ccs/lib
libs=-lnsl -lnm -lndbm -lgdbm -ldb -lmalloc -ldld -lm
perllibs=-lnsl -lnm -lmalloc -ldld -lm
libc=/lib/libc.sl, so=sl, useshrplib=false, libperl=libperl.a
gnulibc_version=''
Dynamic Linking:
dlsrc=dl_hpux.xs, dlext=sl, d_dlsymun=undef, ccdlflags='-Wl,-E -Wl,-B,deferred '
cccdlflags='-fPIC', lddlflags='-b -L/usr/local/lib -L/opt/local/lib'


Characteristics of this binary (from libperl):
Compile-time options: USE_LARGE_FILES
Built under hpux
Compiled at Nov 8 2005 17:33:19
@INC:
/usr/local/lib/perl5/5.8.7/PA-RISC2.0
/usr/local/lib/perl5/5.8.7
/usr/local/lib/perl5/site_perl/5.8.7/PA-RISC2.0
/usr/local/lib/perl5/site_perl/5.8.7
/usr/local/lib/perl5/site_perl

============================================

:root> ./testPerl060812.pl
Testing Perl basic function !



=============================================

I installed mySQL first, and I test mYSQL by creating database and tables without any issue.

Then I installed PERL 5.8.7. The installationm finished with some warnings:

zcary0q6:root> ./testPerl060812.pl
Testing Perl basic function !
zcary0q6:root> which perl
/usr/bin/perl
zcary0q6:root> perl -V
Summary of my perl5 (revision 5 version 8 subversion 7) configuration:
Platform:
osname=hpux, osvers=11.11, archname=PA-RISC2.0
uname='hp-ux hades b.11.11 u 9000800 1335053341 unlimited-user license '
config_args='-d -e -Dcc=gcc -Dprefix=/usr/local useposix=true'
hint=recommended, useposix=true, d_sigaction=define
usethreads=undef use5005threads=undef useithreads=undef usemultiplicity=undef
useperlio=define d_sfio=undef uselargefiles=define usesocks=undef
use64bitint=undef use64bitall=undef uselongdouble=undef
usemymalloc=n, bincompat5005=undef
Compiler:
cc='gcc', ccflags ='-D_HPUX_SOURCE -fno-strict-aliasing -pipe -I/usr/local/include -D_LARGEFILE_SOURCE',
optimize='-O2',
cppflags='-D__STDC_EXT__ -D_HPUX_SOURCE -D_HPUX_SOURCE -fno-strict-aliasing -pipe -I/usr/local/include'
ccversion='', gccversion='4.0.2', gccosandvers=''
intsize=4, longsize=4, ptrsize=4, doublesize=8, byteorder=4321
d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
ivtype='long', ivsize=4, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=4
alignbytes=8, prototype=define
Linker and Libraries:
ld='/usr/bin/ld', ldflags =' -L/usr/local/lib -L/opt/local/lib'
libpth=/usr/local/lib /opt/local/lib /lib /usr/lib /usr/ccs/lib
libs=-lnsl -lnm -lndbm -lgdbm -ldb -lmalloc -ldld -lm
perllibs=-lnsl -lnm -lmalloc -ldld -lm
libc=/lib/libc.sl, so=sl, useshrplib=false, libperl=libperl.a
gnulibc_version=''
Dynamic Linking:
dlsrc=dl_hpux.xs, dlext=sl, d_dlsymun=undef, ccdlflags='-Wl,-E -Wl,-B,deferred '
cccdlflags='-fPIC', lddlflags='-b -L/usr/local/lib -L/opt/local/lib'


Characteristics of this binary (from libperl):
Compile-time options: USE_LARGE_FILES
Built under hpux
Compiled at Nov 8 2005 17:33:19
@INC:
/usr/local/lib/perl5/5.8.7/PA-RISC2.0
/usr/local/lib/perl5/5.8.7
/usr/local/lib/perl5/site_perl/5.8.7/PA-RISC2.0
/usr/local/lib/perl5/site_perl/5.8.7
/usr/local/lib/perl5/site_perl
.
=============================================




James R. Ferguson
Acclaimed Contributor

Re: File::Glob Error

Hi:

The module 'File::Glob' is part of the core module set. You can verify its existence with:

# perldoc -l File::Glob

You should get something like:

/opt/perl/lib/5.8.2/PA-RISC2.0/File/Glob.pm

...returned showing its path.

On one of my servers i have (correspondingly):

# perl -le 'print for (@INC)'
/opt/perl/lib/5.8.2/PA-RISC2.0
/opt/perl/lib/5.8.2
/opt/perl/lib/site_perl/5.8.2/PA-RISC2.0
/opt/perl/lib/site_perl/5.8.2
/opt/perl/lib/site_perl
.


Regards!

...JRF...