General
cancel
Showing results for 
Search instead for 
Did you mean: 

GNOME Desktop won't load.....

SOLVED
Go to solution
Scott McDade
Frequent Advisor

GNOME Desktop won't load.....

I am using Redhat Linux 5.3 32 bit Desktop Edition and I am not able to login my GNOME desktop.   When I attempt to login it gives me a error stating: 

 

---------------------------------------- Error Info---------------------------------------

 

Your session only lasted less than 10 seconds. If you have not logged out yourself, this could mean that there is some installation problem or that you may be out of disk space. Try logging in with one of the failsafe sessions to see if you can fix this problem.

 

This is the content of ~/.xsessions file: 

_X11TransSocketINITCONNECT () can’t get address for wt2100 Name or Service no known

(gnome-session:13612): Gtk – WARNING ** : can’t open display:

 

---------------------------------------- End of Error Info---------------------------------------

 

-It’s interesting as the machine (wts2100) is on the next work and I can login into it using telnet and ftp.

-I can’t find this .xsessions-error file anywhere the above is from the stdout.

-This happens both as a standard user and as root.

-Has anyone seen this and can you advise me what it could be or what logs file to look at?

 

 

Thanks … Scott

Keep it Simple!~
3 REPLIES
Matti_Kurkela
Honored Contributor
Solution

Re: GNOME Desktop won't load.....

This looks like a hostname resolution issue.

 

First, make sure the system has its own hostname listed in /etc/hosts, and that it exactly matches the hostname configured in /etc/sysconfig/network. I notice your error message from .xsessions says it's looking for wt2100 while you wrote the system name is wts2100. Perhaps one or the other has a typo in it?

 

If the system has a statically-configured IP address, the hostname name should traditionally be associated with the system's real IP address in /etc/hosts. But if the system uses DHCP, the name should be associated with 127.0.0.1. That's a trick RedHat uses to get the hostname associated with a sensible IP address while the actual IP of the NIC might change, or the NIC might not have no IP at all if the network connection is disconnected (think laptops).

 

Run "getent hosts wt2100" to see the actual result of the gethostbyname() system call with your current /etc/hosts, /etc/nsswitch.conf & /etc/resolv.conf settings. In RHEL, the nslookup command uses DNS servers only, no matter what is specified in nsswitch.conf. Issues in determining the system's own hostname and the IP address associated with it can cause the X session to fail. Services like telnet and FTP aren't nearly as picky about the system's own identity.

MK
Scott McDade
Frequent Advisor

Re: GNOME Desktop won't load.....

Hello MK:

 

Thanks for the tips on the /etc/hosts file,  that did the trick.   Ironically I have a RH 4 system configured to be static and it doesn't have the hostname/ipaddress mapping defined in it and it works fine.  

 

THanks again!!!!!

Keep it Simple!~
Matti_Kurkela
Honored Contributor

Re: GNOME Desktop won't load.....

If your RH 4 system has been perfectly registered to DNS (i.e. both hostname -> IP and IP -> hostname lookups are successful), then it works without the hostname in /etc/hosts as long as your DNS server is reachable: the system only needs the appropriate gethostbyname() and gethostbyip() calls to succeed, it does not actually care where  the information comes from.

 

But adding the system's own hostname to /etc/hosts makes the system more robust against DNS problems: it guarantees the system will at least complete booting without too many delays from failing DNS lookup attempts and will be able to start all the normal services even if a DNS server is not available or has no information about the system.

MK