Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Showing results for 
Search instead for 
Did you mean: 

GRUB configuration

shyam singh bisht
Occasional Advisor

GRUB configuration

Hi! everybody

I have installed Rdhat Linux 8.0 on primary master HDD .

I have windows 2k professional on Primary slave .

Now I want to have a menu at the system boot time, from which I can choose the OS of my choice.

I have added the following lines in /boot/grub/menu.lst

title windows 2k
rootnoverify (hd1,0)
chainloader +1

It shows the options , but doesn't boot 2k professional .

Any kind of help will be highly appreciated.

thanks & regards

Sergejs Svitnevs
Honored Contributor

Re: GRUB configuration

If you need to boot Win from a non-first disk, try to exchange BIOS drives virtually, like this:

title windows 2k
map (hd1) (hd0)
rootnoverify (hd1,0)
chainloader +1

Steven E. Protter
Exalted Contributor

Re: GRUB configuration

I have found the best practice is.

Have W2K running first, preferably limited to a single drive/partition.

Then install Linux, use grub as the boot loader.

It will set up and let you run W2K no problems. You can rename the entry for windows to make it clearer.

Steven E Protter
Owner of ISN Corporation
Trusted Contributor

Re: GRUB configuration

Did you add the default parameter?
i.e. "default 1"

# Boot automatically after ten seconds
timeout 10

# Default OS is the second record.
default 1

# Fallback to the first record.
fallback 0

# For the girlies:
title Windows 2000
unhide (hd0,0)
hide (hd0,1)
hide (hd0,2)
rootnoverify (hd0,0)
chainloader +1

# Booting your favo OS:
title Linux
root (hd0,7)
kernel /boot/vmlinuz-2.2.17 root=/dev/hda8 video=matrox:vesa:261


Nothing is more successfull as failure