Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
Showing results for 
Search instead for 
Did you mean: 

HP/Oracle error

Tyrone Seldon
Occasional Contributor

HP/Oracle error

Oracle suggested that it's an HP problem & HP suggest it's a Oracle problem. Has anyone had this problem before?
I'm on a HP9000 K-460 with 4 processors and 1 gig of memory. I'm on a 11.00 operating system.

Recommendation from Oracle support:

In each of these occurances you have the same error stack, as follows:

TNS-12547: TNS:lost contact <-- Oracle's presentation of the error at high level.
TNS-12560: TNS:protocol adapter error <-- Next level down of the error (protocol adapter error)
TNS-00517: Lost contact <-- Lowest Oracle level. lost contact. Why? Because of the next error.
HPUX Error: 32: Broken pipe <----This is the actual error. It is an error that is comming from the HPUX level.

The HPUX error 32 is not an oracle error. This is an HP error.

If the listener is up for a long running time and then this error occurs with no changes in the Oracle configuration, then I would strongly recommend that you speak with HP on this error and see if they can isolate the nature of the problem with you. You will also want to examine the error logs on your OS.

Sridhar Bhaskarla
Honored Contributor

Re: HP/Oracle error


Broken Pipe = Error 32 = signal EPIPE.

This results when a process writes to a FIFO but there is no process has that FIFO open for reading.

1. Check if your network configuration is ok.
2. Check if you are running short of system resources like Shared memory kernel parameters, memory and swap etc.,

If nothing works, relink the oracle executables. It doesn't make sense, but it worked before.

You may be disappointed if you fail, but you are doomed if you don't try
Ulf Lipski

Re: HP/Oracle error


your problem looks like a timeout on your network connection port or your listener process is just blocked by shortage of resources. Try to increase the number of semaphores in the kernel, parameter is nsem.

The other approach is to tune up your network, to make it faster.

How heavy is the load of your machine?

Try to restart the listener regularly and
nice the listener process.


Optimization is the root of all evil.
Andreas D. Skjervold
Honored Contributor

Re: HP/Oracle error

What is the version of your Listener?

The 8.0.x listener on HP-UX has a memory leak that makes it hang and thus can't direct incoming calls to their port/localtion.

If this is the case:
Either upgrade to a 8i Listener or as I do; bounce the listener process weekly.

Only by ignoring what everyone think is important, can you be aware of what everyone ignores!
Alexander M. Ermes
Honored Contributor

Re: HP/Oracle error

Hi there.
Could you send some more details ?
Which Oracle version is it ?
That would help.
Alexander M. Ermes
.. and all these memories are going to vanish like tears in the rain! final words from Rutger Hauer in "Blade Runner"