cancel
Showing results for 
Search instead for 
Did you mean: 

HP Scanjet 2300c

Thomas Milne
Occasional Visitor

HP Scanjet 2300c

I am looking for info on getting an HP scanner to work under Mandrake 9.0.

I can see in /proc/bus/usb/devices this information:

T: Bus=01 Lev=00 Prnt=00 Port=00 Cnt=00 Dev#= 1 Spd=12 MxCh= 2
B: Alloc= 0/900 us ( 0%), #Int= 0, #Iso= 0
D: Ver= 1.00 Cls=09(hub ) Sub=00 Prot=00 MxPS= 8 #Cfgs= 1
P: Vendor=0000 ProdID=0000 Rev= 0.00
S: Product=USB UHCI Root Hub
S: SerialNumber=fb00
C:* #Ifs= 1 Cfg#= 1 Atr=40 MxPwr= 0mA
I: If#= 0 Alt= 0 #EPs= 1 Cls=09(hub ) Sub=00 Prot=00 Driver=hub
E: Ad=81(I) Atr=03(Int.) MxPS= 8 Ivl=255ms
T: Bus=01 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#= 4 Spd=12 MxCh= 0
D: Ver= 1.10 Cls=ff(vend.) Sub=ff Prot=ff MxPS= 8 #Cfgs= 1
P: Vendor=03f0 ProdID=0901 Rev= 1.01
S: Manufacturer=Hewlett-Packard
S: Product=hp scanjet scanner
S: SerialNumber=CN27ZS70RP
C:* #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr= 48mA
I: If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=(none)
E: Ad=81(I) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=02(O) Atr=02(Bulk) MxPS= 64 Ivl=0ms
E: Ad=83(I) Atr=03(Int.) MxPS= 1 Ivl=8ms

however, it does not show up in /dev/usb (?).

Apparently, if I could compile sane with the right binaries, it will load the drivers automatically, but I cannot find the appropriate driver files on my product CD.

any help greatly appreciated.

7 REPLIES
Fabio Aquino
Esteemed Contributor

Re: HP Scanjet 2300c

Hi Thomas


The drivers included in your CD-ROM ARE ONLY supported for windows , not in Linux . I will pass for your some sites that have an alternate driver.




Regards


Fabio
Quando você tem uma meta apaixonante , o que era obstáculo passa a ser etapa.
Thomas Milne
Occasional Visitor

Re: HP Scanjet 2300c

Thank you very much, if you have some links to actual drivers, that would be wonderful, I know I am not the only one looking for them.

Cheers!
Stuart Browne
Honored Contributor

Re: HP Scanjet 2300c

With a bit of luck, you might be able to convince the Sane 'plustek' driver to work, but no guarantee's.

'sane' (2.0.9, the latest) doesn't list the 2300c as a supported device *at all*, but going by the series number, it might work.

I've had luck getting my Cannon (which wasn't explicity listed) working, using 2.0.9 and the Plustek driver. Here's what I had to do (it is all on the sane website, but..), but using the values you'd need to use:

/etc/modules.conf:

options scanner vendor=0x03f0 product=0x0901

/etc/sane.d/saned.conf

usb 0x03f0 0x0901

'modprobe' the 'scanner' module, and start up Sane, and see where you get.

If that doesn't work, then it's off to your favourite search engine, hoping you get a hit.
One long-haired git at your service...
Stuart Browne
Honored Contributor

Re: HP Scanjet 2300c

err, make that sane 1.0.9.. sorry :P typo.
One long-haired git at your service...
Thomas Milne
Occasional Visitor

Re: HP Scanjet 2300c

ok, I am a little further ahead, though I may now have caused more harm than good.

now when i run sane-find-scanner, it detects my device and shows the same values you advised me to put into the /etc/modules.conf and /etc/sane.d/saned.conf. However, running scanimage -L shows no scanner attached to the machine.

I also now show /dev/usb/scanner0, which I did not before.

I installed sane 1.09 (frontends and backends, but I used the source, whereas the other dependant packages like xsane are installed from rpm. xsane now seems to be broken, as when I run it I get an error about not finding libsane.so.1, which is a part of the sane packages. I am going to try installing new xsane packages from source and see how that goes.

I am thinking though, I may not need xsane, as I should be able to use xscanimage, though that does not detect my scanner yet either.

Stuart Browne
Honored Contributor

Re: HP Scanjet 2300c

Unfortunately, it's probably best to use the same version for front/back/x portions.

In any case, I think you are right.. Whilst you may be a bit further ahead, the final step, that being Sane actually being happy with the scanner, doesn't work.

I've had opportunity to read through some other posts on the 'net about this scanner, and it seems you are not the only one having problems.

The chipset that is in the other 2x00c series of scanners is slightly different, and doesn't appear to be compatible with any current Sane drivers.

You might want to look at the development tree's of Sane to see if they will be supporting it in the next version, but it doesn't appear to be in this one.

Sorry.
One long-haired git at your service...
Jorge_36
Occasional Visitor

Re: HP Scanjet 2300c

I'm trying to put it to work under Mdk 8.2
I can see it too with usbview, but sane still doesn't work with this scanner.

I read at sane web page that it's not supported because the chipset is unknown (?). I download usbsnoopy to check the usb communication on a win Pc. I'm working on it.

If you put it to work, please let us know.

Otherwise, I'm thinking about the wrong idea of buying HP scanners because I realize that other brands give full support to Linux on nearly all their models, including scanning apps.

Thanks a lot.

Jorge Roca.