General
cancel
Showing results for 
Search instead for 
Did you mean: 

HP-UX 11, ORACLE 7.3.4.5 and MQSeries 5.1

Lenora Perkins
Occasional Contributor

HP-UX 11, ORACLE 7.3.4.5 and MQSeries 5.1

We are operating on T520 and K370, Oracle 7.3.4.5 and MQSeries 5.1. We are in
the process of upgrading to HP-UX 11.0 and MQSeries 5.1 and have
encountered the following problem:

Applications that use both MQSeries and Oracle produce core dumps without generating errors in either MQSeries error logs or Oracle alert logs. I am under the impression that the error is the result of the difference in POSIX threads between the products.

I would appreaciate any information, anyone can share toward the resoultion of this problem.

Thanks,
Lenora
4 REPLIES
Thomas Schler_1
Trusted Contributor

Re: HP-UX 11, ORACLE 7.3.4.5 and MQSeries 5.1

I wonder if Oracle 7.3.4.5 and MQSeries 5.1 are supported on HPUX 11.x. Oracle 7.3.4.5 is old.

Did you check that out?
no users -- no problems
John Palmer
Honored Contributor

Re: HP-UX 11, ORACLE 7.3.4.5 and MQSeries 5.1

Oracle 7.3.4.5 is supported under 11.00 but you need to install the version for HP-UX 11.

The 10.20 version will not run.
Lenora Perkins
Occasional Contributor

Re: HP-UX 11, ORACLE 7.3.4.5 and MQSeries 5.1

We have installed the Oracle 11.0 version. What I am finding is a conflict between the threads used by Oracle and MQSeries. It seems Oracle 7.3.4.5 uses DCE threads (libcma) and MQSeries uses kernel threads. I believe my problem to be library contention. But have yet to find a solution.

Thanks, Lenora
Lenora Perkins
Occasional Contributor

Re: HP-UX 11, ORACLE 7.3.4.5 and MQSeries 5.1

I was unable to find an acceptable workaround. DId find we could run MQSeries 5.0 on the HP-UX 11.0 system, but that would require all application compiles be performed on a 10.20 system.

We chose to upgrade Oracle to 8.1.6.

Thanks,
Lenora