General
cancel
Showing results for 
Search instead for 
Did you mean: 

HP-UX Error: 12: Not enough space

yc_2
Regular Advisor

HP-UX Error: 12: Not enough space

Hi,

during oracle shutdown, the console display:

HP-UX Error: 12: Not enough space

Any pointer is appreciated.

Environment:
Oracle 8i with oracle finacial app 11i
N-class machine
HP-UX 11.00 with MC/SG
4 CPU
Memory 8GB
swap 21GB



Rgds,
YC
5 REPLIES
linuxfan
Honored Contributor

Re: HP-UX Error: 12: Not enough space

Hi Leong,

You might want to check this out
http://forums.itrc.hp.com/cm/QuestionAnswer/1,1150,0x5694c3d7fb78d4118fef0090279cd0f9,00.html

-HTH
I am RU
They think they know but don't. At least I know I don't know - Socrates
James R. Ferguson
Acclaimed Contributor

Re: HP-UX Error: 12: Not enough space

Hi:

Error-12 is a "not enough memory" error. You may need to configure more swapspace and/or set 'swapmem_on=1'. In the configuration you describe, your swap space seems quite generous, but check your swap utilization with 'swapinfo -ta'.

Your application may also need more stack space. You can increase the kernel 'maxdsiz' ('maxdsiz_64bit' on 64-bit processors) to affect this. My quess is that this is the ceiling you are encountering in your case.

Lastly, make sure that your dynamic buffer cache isn't needlessly consuming memory. I'd set 'dbc_max_pct' to perhaps 5%. The default setting provided are generally far to high.

...JRF...

Re: HP-UX Error: 12: Not enough space

I habe seen, you have enough of space and memory.
You must verifyng the Kernnel and Init.ora parameters.
kernel Param.:
shmmax 17 GB (for 64Bit) 1,7 for 32Bit
maxdsiz_64bit 17 Gb maxdsiz 99005648 for 32b
SGA-Parametrs in init.ora:
Redolog Buffers
database buffer pool
shared pool buffers
the SGA must be smaller than th shmmax.
gut luck
mohamed
the world of unix is beautifull

Re: HP-UX Error: 12: Not enough space

An overflow for ninode or nfile is possible??
Mladen Despic
Honored Contributor

Re: HP-UX Error: 12: Not enough space

If your pseudo-swap is enabled, and you run 'swapinfo -tam' you will see a 'memory' line in the output. If this line shows a high percentage (say over 90%), your pseudo-swap reservations are close to the limit. Unfortunately, when Oracle locks memory, it actually contributes to this percentage. I have received a second-hand information that Oracle actually recommends DISABLING psuedo-swap for this reason.

This may not be case on your system, but check the output of 'swapinfo -tam'