cancel
Showing results for 
Search instead for 
Did you mean: 

HP-UX Error: 27: File too large

SOLVED
Go to solution

HP-UX Error: 27: File too large

Trying to do my Oracle backups using RMAN and I got the ff message:
-------------------------
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-03007: retryable error occurred during execution of command: backup
RMAN-07004: unhandled exception during command execution on channel c1
RMAN-10035: exception raised in RPC: ORA-19504: failed to create file "/u04/lvol
2/backup/full/FULL_ICDB_3_1"
ORA-27044: unable to write the header block of file
HP-UX Error: 27: File too large
Additional information: 2
RMAN-10031: ORA-19624 occurred during call to DBMS_BACKUP_RESTORE.BACKUPPIECECRE
ATE

RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-00558: error encountered while parsing input commands
RMAN-01005: syntax error: found ";": expecting one of: "allocate, alter, beginli
ne, catalog, change, connect, create, crosscheck, configure, debug, delete, drop
, exit, endinline, host, {, library, list, mount, open, print, register, release
, replace, report, renormalize, reset, resync, rman, rpct~$???~(???~$@8U???"
RMAN-01007: at line 0 column 22 file: standard input

RMAN>
---------------------------------
Any ideas?

Thanks.
8 REPLIES
Patrick Wallek
Honored Contributor
Solution

Re: HP-UX Error: 27: File too large

Sounds like you are trying to create a file that is larger than 2GB on a filesystem that is not set for large files.

To check and see if your filesystem has largefile enabled do:

# fsadm /mount_point

It will say 'largefiles' or 'nolargefiles'.

To enable 'largefiles' if it is not already done do:

# fsadm -o largefiles /mount_point
Helen French
Honored Contributor

Re: HP-UX Error: 27: File too large

S.K. Chan
Honored Contributor

Re: HP-UX Error: 27: File too large

A few thing you need to check.
1) ulimit
2) vxfs filesystem setup
3) NFS write ?

For 1, if ulimit returns value more than 4194304 than you shold be able to
create a single file more than 2GB in size.
For 2, on the LV you're writing the file to (eg: /dev/vg02/lvol2) run thi as
root :-
# fsadm -F vxfs /dev/vg02/rlvol2
If it returns "nolargefile", meaning the LV does not have largefile option
enable. If this is the case (if you don't have ONlineJFS), you got to umount
the FS, and run this ..
# fsadm -F vxfs -o largefile /dev/vg02/rlvol2 /file
(assuming it's mounted on /file)
Then edit fstab appropriately and mount the FS back.
For 3, this I'm not sure ... are you writing the file to a NFS mounted FS? I
think there is a limitation on file size across NFS.
Sanjay_6
Honored Contributor

Re: HP-UX Error: 27: File too large

hi,

Like patrick has suggested, check for largefiles. your filesystem should have largefiles enabled if you are trying to create a file whose size is bigger than 2GB. You may not be modify the largefiles option online if you don't have onlineJFS. If you don't have online jfs on the system, you'll have to unmount the logical volume, and do a fsadm on this lv to modify the largeiles parameter,

fsadm -o largefiles /dev/vg_name/lv_name

Also Make sure you modify the /etc/fstab entry to reflect this change.

Hope this helps.

Regds
Sandip Ghosh
Honored Contributor

Re: HP-UX Error: 27: File too large

May be the filesystem what you have created for backup /u04 is not a largefilesystem. Whenever any file will be exceeding 2GB it will give the same problem.

If you are having Advanced vxfs you can change it online by

fsadm -o largefiles /u04

otherwise unmount the filesystem. Create a new filesytem on the same logical volume with largefile option and mention it as largefiles in the fstab during mounting the filesystem.

Sandip
Good Luck!!!
S.K. Chan
Honored Contributor

Re: HP-UX Error: 27: File too large

Even though there RDBMS now allows datafiles greater than 2Gig, the utilities might be still limited to 2G. I recommend check with Oracle to be sure.

Re: HP-UX Error: 27: File too large

Hi Patrick,

Your advice worked to perfection as I am able to do my RMAN backups now (as least it started with no problems so far - crossing my fingers).

Thanks again for all your help and thanks to everyone else for sending me your valuable input.

Learning something new everyday (and lovin' it!),

Brando
Andreas D. Skjervold
Honored Contributor

Re: HP-UX Error: 27: File too large

Hi

Just want to add that this behavior in RMAN is due to the fact that RMAN allocates filesize big enough to fit the entire backupset based upon the full database size. When backup proceeds the actual size may end up smaller depending on how much data is loaded into the database.

This maxsize can be set using the RMAN parameter "setlimit" in the backupscript:
run {
allocate channel c1 type disk ....;
setlimit channel c1 kbytes 2000000;

Andreas
Only by ignoring what everyone think is important, can you be aware of what everyone ignores!