Showing results for 
Search instead for 
Did you mean: 

HP UX troubleshooting

Occasional Visitor

HP UX troubleshooting


I´ve worked recently with a workstation B2600 with HPUX 10.20 operating system. Actually I am new with HPUX 10.x.

The following problem occurred: I´ve rebooted the machine through INIT 0 command. After that I couldn´t anymore loggin in it with CDE. I mean when I reboot the system it will complete the loading screen but won´t boot into CDE. All I get is a gray screen with a mouse cursor in it.
I´ve either reboot or shutdown the machine onto a couple of times but always with the same results.
Some help will be appreciated. I´ve tried many things got from HP user´s guide without successs. I´m comp
Bryan D. Quinn
Respected Contributor

Re: HP UX troubleshooting


First thing I would do is boot to a command line or into single user mode by interrupting the boot. I would then check your /etc/hosts file and make sure that the hostname for that box is in the /etc/hosts file correctly. If not, correct it or add it and reboot.

Hope this helps!
Michael Tully
Honored Contributor

Re: HP UX troubleshooting

Your problem is in what runs in what run level. Th CDE starts as part of S990dtlogin.rc
This script runs in run level 3. So in order to get CDE to work and work properly, either run your system into level 3. You need to to do this as networking also needs to be available.

Anyone for a Mutiny ?
Geoff Wild
Honored Contributor

Re: HP UX troubleshooting

Michael's got it.

In future - reboot like this:

shutdown -r now

Do a man shutdown for more info.

Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.
Steven E. Protter
Exalted Contributor

Re: HP UX troubleshooting

As noted init 0 isn't how to boot an hp box, its shuts it down nicely enough.

You need to do some work in single user mode.


Interupt at thte 10 second prompt.


Y For interact

hpux -is

When there, find the mount command

/sbin/mount /usr

Now you can work with the tools you should be used to.

vi /etc/inittab


Make sure the init level of the machine is defaulting to 3. It might not be.

save the file.

vi /etc/rc.log

See if there is an error that is preventing the system from finishing boot.


See if a filesystem like root is too full.

Report back your findings.

shutdown -ry now

to reboot the box. The rc.log file should help a lot. Let someone here know what it says.

Steven E Protter
Owner of ISN Corporation
Esteemed Contributor

Re: HP UX troubleshooting


If Network is up you can telnet and check /var/dt/Xerrors.
can be , name resolution problem or heyboard , mouse device fail.

enjoy any little thing in my life