cancel
Showing results for 
Search instead for 
Did you mean: 

HP Web server issue

SOLVED
Go to solution
Jayan Nair
Frequent Advisor

HP Web server issue

Hi
OS – HP UX itanium 11.31
Siebel is implemented on this OS
#./apachectl -V
Server version: Apache/2.2.8 HP-UX_Apache-based_Web_Server (Unix)
Server built: May 7 2010 12:11:23
Server's Module Magic Number: 20051115:11
Server loaded: APR 1.2.12, APR-Util 1.2.12
Compiled using: APR 1.2.12, APR-Util 1.2.12
Architecture: 64-bit
Server MPM: Worker
threaded: yes (fixed thread count)
forked: yes (variable process count)

Siebel will support 32 bit webserver only. After installing Siebel, we tried starting the web server and got the below error,

#cd /opt/hpws22/apache/bin
#. ./apachectl start
httpd: Syntax error on line 628 of /opt/hpws22/apache/conf/httpd.conf: Cannot load /opt/hpws22/apache/modules/libmod_swe.so into server: '/opt/hpws22/apache/modules/libmod_swe.so' is not a valid load module: Bad magic number.

do we need to uninstall 64 bit apache and install 32 but veriosn.
just installation of 32 is enough.
please advice
7 REPLIES
Mounaam
Trusted Contributor

Re: HP Web server issue

Hi,

hpuxws22Apache (64-bit) is in /opt/hpws22/apache
and
hpuxws22Apch32 (32-bit) is in /opt/hpws22/apache32

So they can coexist on the same system.

Regards,
Mounaam
Jayan Nair
Frequent Advisor

Re: HP Web server issue

Hi Mounaam,
could you please more specific on this.
i need to stop the apache and start which is in /opt/hpws22/apache32/bin/apachectl. Am I correct.
Shibin_2
Honored Contributor
Solution

Re: HP Web server issue

Yes, try to start 32-bit apache
Regards
Shibin
Jayan Nair
Frequent Advisor

Re: HP Web server issue

Hi
In my system apache32 is not available
i have downloaded 32bit version. Before installing do i need to uninstall current installed version.

Torsten.
Acclaimed Contributor

Re: HP Web server issue

>> httpd: Syntax error on line 628


You should check the config file

/opt/hpws22/apache/conf/httpd.conf

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Jayan Nair
Frequent Advisor

Re: HP Web server issue

This is for Siebel. Siebel supported version is
HP Web Server v2.16 32-bit and HP Web Server 3.0.3 32-bit.
So any way I can't use 64 bit.

While uninstalling asking to uninstall dependent sw hp system management and partion manager.
Dennis Handly
Acclaimed Contributor

Re: HP Web server issue

>Before installing do i need to uninstall current installed version?

If it installs in a different location, you may want to install both.

>While uninstalling asking to uninstall dependent sw hp system management and partition manager.

This is why you don't want to remove the current, if you can.