cancel
Showing results for 
Search instead for 
Did you mean: 

HPUX 11i error

SOLVED
Go to solution
Scott McDade
Frequent Advisor

HPUX 11i error

Hello:

I am running HPUX 11i using CDE. I modified my /etc/profile to add in an environment variable and now I am getting this warning everytime I open a terminal window. I have since removed the env variable from the /etc/profile and the warning still appears. Any help would be appreaiated.

---------------- Warning Message --------------


Warning! One or more of your selected locales are not available.
Please invoke the commands "locale" and "locale -a" to verify your
selections and the available locales.

Continuing processing using the "C" locale.


(specs@ACT01)[/home/specs] 367:
$

Keep it Simple!~
9 REPLIES
Torsten.
Acclaimed Contributor

Re: HPUX 11i error

>> I have since removed the env variable from the /etc/profile



So now check

.profile
.dtprofile

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Matti_Kurkela
Honored Contributor
Solution

Re: HPUX 11i error

Which version of HP-UX 11i are we talking about?

11i v1 = 11.11
(11i v1.5 = 11.20 Itanium-only, obsoleted)
(11i v1.6 = 11.22 Itanium-only, obsoleted)
11i v2 = 11.23
11i v3 = 11.31

Which environment variable did you add? (Yes, I know you think you removed it later.)

You probably logged out of CDE and then back in after adding your secret variable. Did you try logging out & back in after removing it too?
When you're using CDE, /etc/profile can be executed when logging in to CDE too. This ensures any desktop menu items will behave just the same as when started from the command line. It also allows terminal windows to start up faster because there is no need to initialize them as "full" login shells - they just inherit their environment variables from the CDE session.

The system is trying to help you - as it says, it would be important to look at the output of the "locale" command, so please copy&paste the output into this thread.

MK
MK
Scott McDade
Frequent Advisor

Re: HPUX 11i error

Hey MK:

I am using B11.11 and the pesky varible i added was MCS_TOOL_NUM. I logged out and back in and even rebooted. Here is the output for the locale command.

LANG=BASIC
LC_CTYPE="C"
LC_COLLATE="C"
LC_MONETARY="C"
LC_NUMERIC="C"
LC_TIME="C"
LC_MESSAGES="C"
LC_ALL=
Keep it Simple!~
Steven Schweda
Honored Contributor

Re: HPUX 11i error

Throw a "set -v" and/or "set -x" into one of
these shell start-up files to try to see who
triggers the message?
Dennis Handly
Acclaimed Contributor

Re: HPUX 11i error

>LANG=BASIC

This is NOT a valid locale. If you want American Nerd, you need to unset the variable or use "C".
Matti_Kurkela
Honored Contributor

Re: HPUX 11i error

MCS_TOOL_NUM is most likely completely unrelated to your locale error message.

LANG=BASIC on the other hand would definitely cause the locale error message. LANG is one of the environment variables defining the locale settings.

LANG is one of the standard system environment variables described in environ(5) man page:
-----
LANG

Identifies the user's requirements for native language, local customs and coded character set, if the environment variables LC_ALL, LC_COLLATE, LC_CTYPE, LC_MESSAGES, LC_MONETARY, LC_NUMERIC, and LC_TIME are unset or null.

The format of LANG is:
LANG=language[_territory][.codeset]

The valid values for LANG are supported locales. (See lang(5).)
----

And to see the full list of supported locales, you can use the "locale -a" command... just as the original error message suggested.

Apparently someone else may have added the invalid "LANG=BASIC" setting at about the same time as you added MCS_TOOL_NUM.

As Dennis said, for traditional Unix behavior and ASCII character set, you can leave the LANG completely unset, or set it to value "C" or "POSIX" - all these three alternatives should result in exactly the same behaviour.

If you wish to use UTF-8 character encoding, the appropriate value for LANG in the US would be "C.utf8" or "en_US.utf8".

MK
MK
Scott McDade
Frequent Advisor

Re: HPUX 11i error

Hey MK:

I am sure you are corect in that it is the LANG=BASIC that is causing the issue. Any idea how I can change that? I don't see that being defined in the /etc/profile.

-S
Keep it Simple!~
James R. Ferguson
Acclaimed Contributor

Re: HPUX 11i error

Hi Scott:

> I am sure you are corect in that it is the LANG=BASIC that is causing the issue. Any idea how I can change that? I don't see that being defined in the /etc/profile.

As Torsten said, look too in '${HOME}/.profile' and '${HOME}/.dtprofile'.

If you don't see an obvious "LANG=" setting, make sure that one of the login profiles isn't sourcing (reading) another local configuration file that in turn is causing the mis-setting.

Regards!

...JRF...
Dennis Handly
Acclaimed Contributor

Re: HPUX 11i error

>Any idea how I can change that? I don't see that being defined in the /etc/profile.

Scan your . files for the word BASIC?
Add "set -x" in your ~/.profile and see where LANG is set.