Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Help! Java setup problem or jdbc problem

Highlighted
Steve Yang_2
Advisor

Help! Java setup problem or jdbc problem

I got a error when I was trying to install an application.

HP-UX11.00
JAVA 1.4.2
ORACLE 9.2.0.1
All required patches have been applied.

The error is as follows:

Check setup of Oracle Server / Oracle Client / LD_LIBRARY_PATH
java.lang.UnsatisfiedLinkError: no ocijdbc9 in java.library.path
Error connecting to Database: demo via TNS Name: demo
Error TNS Connection
(Error connecting to Database: demo via TNS Name: demo)

Any idea will be welcome.

Thanks.
steve_yxf
2 REPLIES
Steven E. Protter
Exalted Contributor

Re: Help! Java setup problem or jdbc problem

Last I checked Java 1.4 was not certified with all versions of Oracle.

Having the right patches for the wrong java won't help.

check the certification matix at http://metalink.oracle.com (best) or http://otn.oracle.com on that one.

swverify that the applied patches applied correctly.

We're using Java 1.3 with that version of Oracle, since upgraded to 9.2.0.4(which you need to do for serious bugs) no problem at all.

sEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Steven E. Protter
Exalted Contributor

Re: Help! Java setup problem or jdbc problem

Last I checked Java 1.4 was not certified with all versions of Oracle.

Having the right patches for the wrong java won't help.

check the certification matix at http://metalink.oracle.com (best) or http://otn.oracle.com on that one.

swverify that the applied patches applied correctly.

We're using Java 1.3 with that version of Oracle, since upgraded to 9.2.0.4(which you need to do for serious bugs) no problem at all.

Also check SHLIB_PATH in the startup script for the database.

sEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com