Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

How configure RedHat allowing printing request from HPUX?

twang
Honored Contributor

How configure RedHat allowing printing request from HPUX?

Hi,
I would like to install a remote printer on HPUX, and that printer was already configured on a linux system, Pls help.

many thanks in advance.

tommy
8 REPLIES
Steven Sim Kok Leong
Honored Contributor

Re: How configure RedHat allowing printing request from HPUX?

Hi,

You have to ensure that your LPD daemon is running on your RedHat system to be able to serve remote lp requests ie.

[root@abc /root]# ps -fae|grep lpd
lp 28206 1 0 17:34 ? 00:00:00 lpd Waiting

If it is not, check that your lpd startup script runs during system startup:

[root@abc /root]# grep :initdefault: /etc/inittab
id:3:initdefault:
[root@abc /root]# ls /etc/rc.d/rc3.d/*lpd
/etc/rc.d/rc3.d/S60lpd

The 60lpd must be prefixed by a capital S and not a small letter s.

From the HP-UX client, configure a remote printer queue using SAM.

If you are running iptables or ipchains, please ensure that inbound traffic to port TCP/515 on your RedHat system has not been blocked.

Hope this helps. Regards.

Steven Sim Kok Leong
Brainbench MVP for Unix Admin
http://www.brainbench.com
Email: steven@beepz.com. Homepage: https://www.beepz.com
twang
Honored Contributor

Re: How configure RedHat allowing printing request from HPUX?

Hello Steven,

I got the following output from RedHat server:

[root@wlinux1 /root]# ls /etc/rc.d/rc3.d/*lpd
/etc/rc.d/rc3.d/S60lpd
[root@wlinux1 /root]# grep :initdefault: /etc/inittab
id:5:initdefault:
[root@wlinux1 /root]# ps -fae|grep lpd
root 569 1 0 Mar26 ? 00:00:00 lpd
[root@wlinux1 /root]# grep :initdefault: /etc/inittab
id:5:initdefault:
[root@wlinux1 /root]# ls /etc/rc.d/rc3.d/*lpd
/etc/rc.d/rc3.d/S60lpd
[root@wlinux1 /root]#


I have tried to add a remote printer queue in HP-UX client and got the following info;

# lpstat -a
prt01 accepting requests since Oct 12 11:26
prt02 accepting requests since Mar 5 10:31
# lpstat -d prt02
system default destination: prt01

printer queue for prt02
wlinux1: lpd: prt: Your host does not have line printer access

wmo_a: prt02: ready and waiting
no entries
#

It seems that the RedHat does not enable its remote printing service. Is this right?

Many thanks

tommy
Steven Sim Kok Leong
Honored Contributor

Re: How configure RedHat allowing printing request from HPUX?

Hi,

Check if it is a TCP or network connectivity issue before proceeding with testing the configuration by trying the following from your HP-UX system:

# telnet linux-host 515

If the output is

Trying...
Connected to linux-host.
Escape character is '^]'.

then, your TCP connection is fine.

However, if the output is

Trying...
telnet: Unable to connect to remote host: Connection refused

then, your TCP connection is likely to have been blocked or there is no route from your HP-UX system to your linux system.

If your TCP connection is fine, you will need to check the configuration settings you set at your HP-UX system. Perform this:

# /usr/sam/lbin/lpmgr|grep remote-printer-queue

where remote-printer-name refers to the printer queue you named for the remote linux printer. This will show the configuration of your remote printer queue.

Hope this helps. Regards.

Steven Sim Kok Leong
Brainbench MVP for Unix Admin
http://www.brainbench.com
Email: steven@beepz.com. Homepage: https://www.beepz.com
twang
Honored Contributor

Re: How configure RedHat allowing printing request from HPUX?

Hi,
Thanks for your quick reply, I think I have set somethin wrong on RedHat:

# telnet wlinux1 515
Trying...
Connected to wlinux1.
Escape character is '^]'.
lpd: prt: Malformed from address
Connection closed by foreign host.

# /usr/sam/lbin/lpmgr|grep prt02
prt02:remote:yes, idle:yes:prt on wlinux1:0: :

Anything does the above message indicate?

thanks

tommy
Steven Sim Kok Leong
Honored Contributor

Re: How configure RedHat allowing printing request from HPUX?

Hi,

The printer queue settings at your linux system might have been misconfigured.

Further debugging,

On your linux system:

# /etc/rc.d/init.d/lpd stop
# lpd -D1 -F

From your hpux system:

# telnet linux-system 515

Record the debug messages on your linux system.

Hope this helps. Regards.

Steven Sim Kok Leong
Brainbench MVP for Unix Admin
http://www.brainbench.com
Email: steven@beepz.com. Homepage: https://www.beepz.com
twang
Honored Contributor

Re: How configure RedHat allowing printing request from HPUX?

Hello,
I carry out the following steps and produce the same result,
On Linux printer server side:

[root@wlinux1 /etc]# ps -ef |grep lpd
root 1545 1 0 12:06 ? 00:00:00 lpd
root 1699 1429 0 14:34 pts/0 00:00:00 grep lpd
[root@wlinux1 /etc]# /etc/rc.d/init.d/lpd stop
Shutting down lpd: [ OK ]
[root@wlinux1 /etc]# lpd -D1 -F
[root@wlinux1 /etc]# ps -ef |grep lpd
root 1715 1 0 14:35 ? 00:00:00 lpd -D1 -F
root 1718 1429 0 14:35 pts/0 00:00:00 grep lpd
[root@wlinux1 /etc]#


On HP-UX client side:

# telnet wlinux1 515
Trying...
Connected to wlinux1.
Escape character is '^]'.
lpd: prt: Malformed from address
Connection closed by foreign host.
#


Best regards
tommy
Steven Sim Kok Leong
Honored Contributor

Re: How configure RedHat allowing printing request from HPUX?

 
Email: steven@beepz.com. Homepage: https://www.beepz.com
Tarmo Loorits
Occasional Visitor

Re: How configure RedHat allowing printing request from HPUX?

I recall similar problems trying to redirect HP remote printing to linux LPD. If I remember it correctly, these two daemons have incompatible protocols. Even when some wizard might be able to configure them understand eachother I chose easier solution - replacing LPD coming with RedHat with LPRng.