How to Enable rlogin


How to Enable rlogin

i am using suse linux 8.i want to enable rlogin for this server not happening.but telnet is working which service i ahve to run for this rlogin & which line i have to edit in inetd.conf.
in my server only inetd.conf is there,there is no xinetd dir.for rlogin we need to install any rpm or what.some one help me to close this issue

Steven E. Protter
Exalted Contributor

Re: How to Enable rlogin

Shalom mahen,

inetd.conf can run rlogin protocols as well.

1) Find the software to enable rlogin on your original cd's. Its there. install it.
2) This will probably add the necessary code to inetd.conf, which you will need to restart.

You might want to consider a more up to date version of Suse.

By default, because of serious security issues, rlogin and its sister protocols are not installed in modern Linux.

You might wish to consider openssh, which is installed by default and works almost exactly like rlogin.

Steven E Protter
Owner of ISN Corporation
Ivan Ferreira
Honored Contributor

Re: How to Enable rlogin

The telnet and rlogin services are obsolete because of security issues. You should use SSH as a replacement for all these services.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Valued Contributor

Re: How to Enable rlogin


Try this..

#cd /etc/xinetd.d
#ls -l rlogin
#vi rlogin

disable = no

save and come out

#service xinetd restart

#rlogin server_name

Hope this will solve ur issue.

Never Ever Give Up
Bill Thorsteinson
Honored Contributor

Re: How to Enable rlogin

Try using ssh instead. rlogin is a
security hole and has been disabled
by default on many linux distributions
for some time. ssh provided all the
rlogin functionality over a secure channel.
Sivakumar TS
Honored Contributor

Re: How to Enable rlogin


After enabling the service make sure to add the required hostname entries in

.rhosts and /etc/hosts.equiv

only the hosts listed in this files will be the trusted hosts and can do rcp.. etc

With Regards,

Nothing is Impossible !