General
cancel
Showing results for 
Search instead for 
Did you mean: 

How to enable key Backspace?

Rashid Ali
Frequent Advisor

How to enable key Backspace?

I am using RedHat Linux 6.2. I can use the key Backspace to remove typo error. But when I telnet to HP-UX server, It cannot work and simply display ^? when hitting Backspace. I run "stty" and it shows as below,
speed 9600 baud; evenp hupcl -cread
intr = ^C; erase = ^H; kill = ^U;
swtch ;
brkint -inpck icrnl -ixany ixoff onlcr tab3
-iexten echo echoe echok
-echoctl -echoke

How can I enable Backspace under the telnet session?

Thanks for help,

4 REPLIES
Vincenzo Restuccia
Honored Contributor

Re: How to enable key Backspace?

#stty erase ^?(Backspace)
Evert Jan van Ramselaar
Valued Contributor

Re: How to enable key Backspace?

Try this:
# stty erase [Backspace-key]

(You could do this in your .profile)
Contrary to popular belief, Unix is userfriendly. It just happens to be selective about who it makes friends with.
Rashid Ali
Frequent Advisor

Re: How to enable key Backspace?

Yes, It works. But, is there any way to fix it? So that I don't need to run this command every time I telnet to HP-UX server from Linux and at the same time I can also telnet to the same server from Win98/NT. If I add this command into .profile then once I log on to the server from Win98/NT, I still got the same problem, Is that true?
Mark Fenton
Esteemed Contributor

Re: How to enable key Backspace?

I don't think I understand your question. The command, if located in the .profile on the HP box will execute whether you logon from Linux or anywhere else. Do you mean to ask how to set this property for just your Linux box, because when you execute the command from the Windows client, this fix causes problems?