General
cancel
Showing results for 
Search instead for 
Did you mean: 

How to fix Compaq System Partition Utilities after installing RedHat Linux 7.3

John Galt
Occasional Contributor

How to fix Compaq System Partition Utilities after installing RedHat Linux 7.3

I have an old ProSignia 300 that I just installed RedHat Linux 7.3 on.

I did a manual partitioning to create my partitions so that I didn't wipe out the system partition. I also did a text mode install (I didn't think the old Pentium 120 was up to running the GUI, and I don't need the GUI on this box anyway).

I configured it with GRUB for the boot loader. Now, when the machine boots up, I get the usual "Press F10 for System Partition Utilities" message, but if I press F10, it immediately starts Linux. This is obviously sub-optimal.

I noticed when I went through the GRUB setup parts of the text mode installation I was never given the opportunity to tell it where to put GRUB. I know in the graphic install there is an option to put GRUB in the MBR or in the first sector of the boot partition. With the Compaq machines I've installed Linux on before, I always specified the first sector of the boot partition rather than the MBR and the Compaq Utilities always worked.

I'm guessing that it defaulted to installing GRUB in the MBR and that's why my system partition utilities don't work now.

How can I fix this
1 REPLY
Paulo A G Fessel
Trusted Contributor

Re: How to fix Compaq System Partition Utilities after installing RedHat Linux 7.3

You can add the system utilities partition to the GRUB menu, so you can choose to start it instead of Linux at bootup time.

Also, you can issue a FDISK /MBR and reconfigure GRUB to install itself in the first sector of the boot partition. Both operations are described on GRUB's manuals.

HTH
Paulo Fessel
L'employé propose, le boss dispose.