Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

How to install Perl 5.6.1 DBD:Oracle DBI on 11i with gcc

How to install Perl 5.6.1 DBD:Oracle DBI on 11i with gcc

Hi there,

I need some help on this. What is
the 'proper way' (if there is such a thing)
to install Perl561 DBD:Oracle and DBI on
HPUX 11i 64 bit.
I am running 64 bit Oracle 8.1.7.3
and have downloaded and installed the
GCC64 3.0.2.2001-11-14 depot
and the
Perl B.5.6.1.E depot from hp.
I already read some bad things about the perldepot (threaded and some library or
another missing)

I presume I need to install 64 bit perl?

Any suggestions welcome!
Thanks
/Matt
9 REPLIES
Jordan Bean
Honored Contributor

Re: How to install Perl 5.6.1 DBD:Oracle DBI on 11i with gcc


If you are using 64-bit Oracle, then you must build 64-bit PERL. Either way, PERL should be built as non-threaded, but still be linked to libpthreads so the threaded Oracle libraries will dynamically load.

Re: How to install Perl 5.6.1 DBD:Oracle DBI on 11i with gcc

I downloaded the stable perl source tarball.

I tried to run ./Configure -Dcc=gcc

But it ends up with:
########################################

gcc -o try -O -D_HPUX_SOURCE -L/lib/pa1.1
-DUINT32_MAX_BROKEN -fno-strict-aliasing
-L/usr/local/lib try.c -lcl -lpthread
-lnsl -lnm -lndbm -lmalloc -ldld -lm -lc
-lndir -lcrypt -lsec
./try

and I got the following output:

ld: Can't find library for -lndbm
Fatal error.
collect2: ld returned 1 exit status
I can't compile the test program.
#########################################

Full typescript attached.
Any ideas???

Thanks
/Matt
Jordan Bean
Honored Contributor

Re: How to install Perl 5.6.1 DBD:Oracle DBI on 11i with gcc


I built PERL 5.8.0 using HP ANSI C/C++. Attached is perl -V. Would you like to obtain obtain our 64-bit build with DBI 1.30 and DBD::Oracle 1.12 for 64-bit Oracle 9.0.1?

Re: How to install Perl 5.6.1 DBD:Oracle DBI on 11i with gcc

We do not have the HP Ansi C compiler,
we only have GCC,
will it still work if I want to install
new modules that might need re-compiling?
I am also only running Oracle 8.1.7
will the fact that you are running Oracle 9
make any difference?

Thanks
/Matt
Jordan Bean
Honored Contributor

Re: How to install Perl 5.6.1 DBD:Oracle DBI on 11i with gcc


I do no use gcc, so I'll defer. You'll find more useful info by searching for 'perl 64 dbi dbd oracle'

xie kexian
Contributor

Re: How to install Perl 5.6.1 DBD:Oracle DBI on 11i with gcc

Hi, Jorden
I want to obtain the pre-compiled perl build: 64 bit+DBI+Oracle9i DBD you mentioned on hpux11i. Can you send me the download link or just give me?
Thank you!
Best regards,
Section Xie
It's open that breaks isolation.
Pete Randall
Outstanding Contributor

Re: How to install Perl 5.6.1 DBD:Oracle DBI on 11i with gcc

Matt,

Unfortunately, it's a national holiday in the Netherlands, otherwise Procura (Merijn) would have replied by now. In his absence, you might want to check his web page for perl/oracle builds/downloads:

http://www.cmve.net/~merijn


Pete

Pete
H.Merijn Brand (procura
Honored Contributor

Re: How to install Perl 5.6.1 DBD:Oracle DBI on 11i with gcc

If time permits I might give it a go. Some things to think about before you start downloading when it arrives:

?? It is DBD::Oracle *prepared*, but does not /include/ DBD::Oracle, for all the obvious reasons.
?? It will be build with gcc-3.3 prerelease (which is actually pretty good), but it it is not (yet) available as prebuilt binary
?? It will be built on HP-UX 11.00, not 11i

[ I got your mail, and I know you want 5.6.1. It should not take me too much time, but if it does, I probably better make gcc-3.3/64 available sooner than I planned ]

I'd rather have you choose for 5.8.0/64, because I have to do some tweaking to make 5.6.1 build with gcc-3.3 and would choose to avoid that.

Enjoy, have FUN! H.Merijn
Enjoy, Have FUN! H.Merijn
H.Merijn Brand (procura
Honored Contributor

Re: How to install Perl 5.6.1 DBD:Oracle DBI on 11i with gcc

64bit perl-5.8.0 Oracle prepared built with gcc-3.3 20030421 available on https://www.beepz.com/personal/merijn/ or http://www.cmve.net/~merijn/ as of this afternoon (wait a few days for beepz, uploading is rather sluggish)

Also available the gcc-3.3 I built it with

No guarantees. Usa at own risk. (The perl test suite passed all tests, as did the test suites for all included modules)

Enjoy, have FUN! H.Merijn
Enjoy, Have FUN! H.Merijn