HPE Community read-only access December 15, 2018
This is a maintenance upgrade. You will be able to read articles and posts, but not post or reply.
Dec 15, 4:00 am to 10:00 am UTC
Dec 14, 10:00 pm CST to Dec 15, 4:00 am CST
Dec 14, 8:00 pm PST to Dec 15, 2:00 am PST
Showing results for 
Search instead for 
Did you mean: 

IPMI Support for Integrity HP-UX

Jeff Smith_18
Occasional Visitor

IPMI Support for Integrity HP-UX

Does anyone know if there is a package supporting HP-UX (like hpbmc for HP Linux Integrity)?

I have looked and found only a driver and a tunable.

We need some sort of command line management tools.
Shinji Teragaito_1
Respected Contributor

Re: IPMI Support for Integrity HP-UX

Grab the source code of impitool and build it.


When I built 1.8.9 on HP-UX 11.23 last year, I had none of problems. It works.

Good luck !!
Trusted Contributor

Re: IPMI Support for Integrity HP-UX

I have tried to build on hpux 11.31 on itanium,i tried latest version and 1.8.4 and i get those errors in both version

someone know how to solve?

I have tried this solution but doesn't work




imbapi.c: In function 'MapPhysicalMemory':
imbapi.c:1983: error: 'EXEC_PAGESIZE' undeclared (first use in this function)
imbapi.c:1983: error: (Each undeclared identifier is reported only once
imbapi.c:1983: error: for each function it appears in.)
imbapi.c: In function 'UnmapPhysicalMemory':
imbapi.c:2028: error: 'EXEC_PAGESIZE' undeclared (first use in this function)
Makefile:301: recipe for target 'imbapi.lo' failed
gmake[4]: *** [imbapi.lo] Error 1
gmake[4]: *** Waiting for unfinished jobs....
gmake[4]: Leaving directory '/usr/local/src/ipmitool-1.8.10/src/plugins/imb'
Makefile:331: recipe for target 'all-recursive' failed
gmake[3]: *** [all-recursive] Error 1
gmake[3]: Leaving directory '/usr/local/src/ipmitool-1.8.10/src/plugins'
Makefile:394: recipe for target 'all-recursive' failed
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory '/usr/local/src/ipmitool-1.8.10/src'
Makefile:318: recipe for target 'all-recursive' failed
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory '/usr/local/src/ipmitool-1.8.10'
Makefile:247: recipe for target 'all' failed
gmake: *** [all] Error 2