General
cancel
Showing results for 
Search instead for 
Did you mean: 

Ignite install problem - Invalid Parameter

SOLVED
Go to solution
Unix Administration
Occasional Advisor

Ignite install problem - Invalid Parameter

Hello,

I am trying to install a system, but I am given the following error:

Shell> lanboot select -sip X.X.X.X -cip X.X.X.X -gip X.X.X.X -m 255.255.255.224
01 Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Pci(6|0)/Mac(0025B3E8412A)
02 Acpi(HWP0002,PNP0A03,200)/Pci(1|0)/Pci(6|1)/Mac(0025B3E8412B)
03 Acpi(HWP0002,PNP0A03,300)/Pci(1|0)/Pci(6|0)/Mac(0025B3E83170)
04 Acpi(HWP0002,PNP0A03,300)/Pci(1|0)/Pci(6|1)/Mac(0025B3E83171)
05 Acpi(HWP0002,PNP0A03,400)/Pci(2|0)/Mac(001A4B09B5B4)
06 Acpi(HWP0002,PNP0A03,400)/Pci(2|1)/Mac(001A4B09B5B5)
07 Acpi(HWP0002,PNP0A03,600)/Pci(1|0)/Pci(6|0)/Mac(0025B3E84128)
08 Acpi(HWP0002,PNP0A03,600)/Pci(1|0)/Pci(6|1)/Mac(0025B3E84129)
09 Acpi(HWP0002,PNP0A03,700)/Pci(1|0)/Mac(000CFC00DB09)
Select Desired LAN: 06
Selected Acpi(HWP0002,PNP0A03,400)/Pci(2|1)/Mac(001A4B09B5B5)


Client MAC Address: 00 1A 4B 09 B5 B5
Client IP Address: X.X.X.X
Subnet Mask: 255.255.255.224
BOOTP Server IP Address: X.X.X.X
DHCP Server IP Address: 54.54.48.48
Boot file name:
PXE-E21: Remote boot cancelled.
Exit status code: Invalid Parameter

The message is almost instantaneously. No packets are reaching the install server. If I do not specify an IP, the system is sending DHCP requests, and it takes some time till it fails.

The network problems are eliminated. If I assign that IP and that default gateway to the client in EFI shell, I am able to ping the install server.

Also, I do not know what 54.54.48.48 is. I did not specify it anywhere.

Do you have any idea what this might be? Thank you
7 REPLIES
Torsten.
Acclaimed Contributor

Re: Ignite install problem - Invalid Parameter

IMHO you need to check all your "X" values.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Aneesh Mohan
Honored Contributor

Re: Ignite install problem - Invalid Parameter

Hi,

>> DHCP Server IP Address: 54.54.48.48

If 54.54.48.48 is not your Ignite server then ,you client ip is assigned by some other DHCP source.

Aneesh

Unix Administration
Occasional Advisor

Re: Ignite install problem - Invalid Parameter

This has already been done. They are correct, but the client and the server are in different subnets. The client is not even sending a packet. There is absolutely no traffic detected on the routers.

The error message is instantaneously.

I have read on different threads that there are issues when using different subnets. Is this true?
Torsten.
Acclaimed Contributor

Re: Ignite install problem - Invalid Parameter

Sure you are using the correct NIC?
Is this NIC (MAC) configured at the server side?

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor

Re: Ignite install problem - Invalid Parameter

What server model is it? What firmware? There are several fixed related to LAN boots.

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Torsten.
Acclaimed Contributor
Solution

Re: Ignite install problem - Invalid Parameter

Note:

"When creating a direct boot profile, always define the boot file using the -b option to set the value to /opt/ignite/boot/nbp.efi. This is required to install HP-UX."

http://docs.hp.com/en/5992-6584/ch09s06.html

Hope this helps!
Regards
Torsten.

__________________________________________________
There are only 10 types of people in the world -
those who understand binary, and those who don't.

__________________________________________________
No support by private messages. Please ask the forum!

If you feel this was helpful please click the KUDOS! thumb below!   
Unix Administration
Occasional Advisor

Re: Ignite install problem - Invalid Parameter

Thanks Torsten, this helped. I've seen that info, but I thought it's not required if I mention all the IPs in the lanboot command.

Points assigned