General
cancel
Showing results for 
Search instead for 
Did you mean: 

Informix database recovery problem from Ultrium tape

MQ'ski
Regular Advisor

Informix database recovery problem from Ultrium tape

Hello.
Server is rp4440
HP-UX 11i
Tape drive Ultrium 232
Informix

When I try to recover informix database from full backup after list of files for recovery and question with do you want to continue recover...
I receive error that backup is corrupted.
I found this problem some time ago and the problem was with TAPEBLK parameter (that is in onconfig file) I guess...
I did try to manipulate with different valuses for this parameter but is fruitless...
Problem seems like well known but I can not workaraund it...
Someone can help?
4 REPLIES
Jeeshan
Honored Contributor

Re: Informix database recovery problem from Ultrium tape

try this

Performing a Cold Restore
To perform a cold restore, the database server must be offline.
Youmust log in as user informix or root to use ontape. Execute the following
ontape command to restore all the storage spaces:

ontape -r

When you perform a mixed restore, you restore only some of the storage
spaces during the cold restore. You must restore at least all the critical
dbspaces, as the following example shows:

ontape -r -D rootdbs llogdbs plogdbs
a warrior never quits
Jeeshan
Honored Contributor

Re: Informix database recovery problem from Ultrium tape

if you want to Performing a Cold Restore
To perform a cold restore, the database server must be offline.
Youmust log in as user informix or root to use ontape. Execute the following
ontape command to restore all the storage spaces:

ontape -r

When you perform a mixed restore, you restore only some of the storage
spaces during the cold restore. You must restore at least all the critical
dbspaces, as the following example shows:

ontape -r -D rootdbs llogdbs plogdbs
a warrior never quits
MQ'ski
Regular Advisor

Re: Informix database recovery problem from Ultrium tape

Thaks for advice!...
The problem has been isolated.
In hurry we linked /dev/rmt/0mn instead of /dev/rmt/0m
MQ'ski
Regular Advisor

Re: Informix database recovery problem from Ultrium tape

Mistake
/dev/rmt/0mn must not be used...