Simpler Navigation coming for Servers and Operating Systems
Coming soon: a much simpler Servers and Operating Systems section of the Community. We will combine many of the older boards, and you won't have to click through so many levels to get at the information you need. If you are looking for an older board and do not find it, check the consolidated boards, as the posts are still there.
cancel
Showing results for 
Search instead for 
Did you mean: 

Install Linux on Vectra XU 5/90

Emil Velez_2
Trusted Contributor

Install Linux on Vectra XU 5/90

I am trying to get Redhat 7.2 installed on a Vectra XU 5/90 and I keep getting a kernel panic after the first LILO screen. I have booted from a floppy, I have booted from a CDROM via a siig interface and moved the SCSI hard drive from the built in scsi to the siig interface to no avail.

Something about this box makes linux panic. If anyone knows of a workaround I would appreciate it.

The interesting thing is when I search the internet it mentions that this box does interrupt sharing between the SCSI port and the built in lan and there are other issues since it mentions that this is a MP capable system.

Any assitance or install clues would be appreciated.

Thanks
Emil Velez
Instructor Storage, Servers, HP-UX and Partner Courses
Hewlett Packard Enterprise Education Services
Ask me about training on StoreServ (3PAR) StoreOnce, StoreEasy, StoreAll, StoreVirtual, HP-UX, ServiceGuard and HPE Partner Ready Certification Training

internet: Emil.Velez@hpe.com
Linkedin: http://www.linkedin.com/in/emilvelez

HPE Master ASE Server Solutions Architect V3
HPE Master ASE Storage Solutions Architect V2
HP UNIX Certified (ASE HPUX 11iv3 Administration V1)
Certified HPE Instructor
HPE Product Certified - OneView [2016]
HP Sales Certified -Servers, Converged Systems and Services [2015]
HPE Product Certified - Converged Solutions [2017]
2 REPLIES
Martin Burnett_2
Trusted Contributor

Re: Install Linux on Vectra XU 5/90

Hello Emil,

I did some research on this and it appears that the system contains the HP Vectra XU 5/90 SCSI (AM 79C974 PCscsi, I am assuming this is what is installed in yours...and yes I know what happens when you assume). This PCI/SCSI embedded controller has problems with Linux drivers. I found a lot of instances in the linux news groups that had the same or similar issues with panics.

First the official word...this is not a supported HW configuration for Linux. See http://hp-linux.cern.ch/support/centp.php3. Now that's out of the way, there does seem to be quite a few folks out there using these systems with varying degrees of success.

Here are some of the alternatives those user's came up with, note that I did not use the term solutions, because I did not find any definitive solution for this:

1. I searched dejanews for information on the built-in AMD scsi and everything I read said the linux driver (or the chip) is buggy and unstable -
...I decided to
be safe and popped in an adaptec 2940U and it's never given me a problem.

2. ...I don't have the machine in front of me but there are two settings in the BIOS that have to do with the onboard SCSI. One of them allows you to turn off the
SCSI BIOS. Do this, as it doesn't play nice with the driver.

3. I took the external drive to another Linux system and I was able to create the partitions with no problem. But as soon as I try to use the AMD SCSI controller the installation bombs.


Probably not what you hoped for but maybe this helps.

Martin


Robert Gadsdon
Occasional Visitor

Re: Install Linux on Vectra XU 5/90

I have installed Linux on several of these over the years, and they have all been 'fun'..

Things to watch out for:

Make sure the Distro is not trying to install the old 53c974 SCSI driver - this is known to be 'bad' and will produce many of the symptoms descibed in previous postings - use the (much better) TMSCSIM driver. The later Red Hat distros (7.3) seem to use the right driver by default (found on the extra 'drivers' floppy).

If you can, remove the SCSI disk and use a spare old IDE one instead (but remember that the bios will not correctly recognise any over 4MB, although Linux will). I have successfully used two old 4MB IDE disks in an XU/90, keeping the CDROM on the SCSI connection.

Use LILO with the LINEAR option, and put the 'boot' directory on a separate partition (the first one on the first disk). Make sure the first disk is not over 4MB (you need to use an _old_ one..) This should (hopefully) avoid the 'LI...' problems.

If you have both CPUs installed, make sure that the uniprocessor kernel is also available from LILO ("linux-up") in case of interrupt problems etc. when booting the SMP kernel.

As has been mentioned before, this mobo/scsi combination (using the old 'Neptune' chipset) is not exactly bug-free. _If_ you have the skills, I would also recommend compiling your own kernel, especially for reliable SMP support...