Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Install Oracle 9i on Red hat linux enterprise 5 error

Z.K.
Frequent Advisor

Install Oracle 9i on Red hat linux enterprise 5 error

We are installing Oracle 9.2.04 on Linux.
We set the environment as follows:
  export BASH_ENV=$HOME/.bashrc
  Oracle_HOME=/Oracle/product/9.0.1; export Oracle_HOME
  Oracle_SID=Oracle; export Oracle_SID
  Oracle_TERM=xterm; export Oracle_TERM
  TNS_ADMIN=/home/Oracle/config/9.0.1; export TNS_ADMIN
  NLS_LANG=american_america.ZHS16GBK; export NLS_LANG
  ORA_NLS33=$Oracle_HOME/ocommon/nls/admin/data; export ORA_NLS33
  LD_LIBRARY_PATH=$Oracle_HOME/lib;export LD_LIBRARY_PATH
  PATH=$PATH:/bin:/usr/bin:/usr/sbin:/etc:/opt/bin:
  /usr/ccs/bin:/usr/openwin
  PATH=$PATH:/opt/local/bin:/opt/NSCPnav/bin:$Oracle_HOME/bin
  PATH=$PATH:/usr/local/samba/bin:/usr/ucb:
  export PATH
  CLASSPATH=$Oracle_HOME/JRE:$Oracle_HOME/jlib:
  $Oracle_HOME/rdbms/jlib
  CLASSPATH=$CLASSPATH:$Oracle_HOME/network/jlib
  TMPDIR=/tmp;export TMPDIR
  umask 022


After setting the environment, we did:
[Oracle@localhost Disk1]# ./runInstaller &
and got an missing file problem(missing file libstdc++-libc6.1-1.so.2).
Then we did:
[Oracle@localhost lib]# ln -sf libstdc++.so.6.0.8 libstdc++-libc6.1-1.so.2

After that, the missing file problem is settled.
But when we execute runInstaller again, the program hang at :
Initializing Java Virtual Machine from /tmp/OraInstall2007-06-28_09-36-35AM/jre/bin/java. Please wait...

With no other error messages.
What should we do next?
11 REPLIES
Heironimus
Honored Contributor

Re: Install Oracle 9i on Red hat linux enterprise 5 error

Different versions of libstdc++ are not binary compatible. You probably need to install compat-libstdc++-296 to get the right version of the shared library.

Even with that I'm not sure if Oracle 9i will really work on RHEL5. It was easy on 2.1 but got much more difficult on later releases.
Z.K.
Frequent Advisor

Re: Install Oracle 9i on Red hat linux enterprise 5 error

Thanks for your reply!
I'll have a try again.
Jeeshan
Honored Contributor

Re: Install Oracle 9i on Red hat linux enterprise 5 error

try to update your libstdc++-libc rpm
a warrior never quits
Hemmetter
Esteemed Contributor

Re: Install Oracle 9i on Red hat linux enterprise 5 error

Hi Z.K.,

install that compat-* library rpm:


# ll /usr/lib/libstdc++-libc6.1-1.so.2
lrwxrwxrwx 1 root root 30 Feb 5 14:09 /usr/lib/libstdc++-libc6.1-1.so.2 -> libstdc++-2-libc6.1-1-2.9.0.so

# rpm -qf /usr/lib/libstdc++-2-libc6.1-1-2.9.0.so
compat-libstdc++-7.3-2.96.128


rgds
HGH



Don Vanco - Linux Ninja
Regular Advisor

Re: Install Oracle 9i on Red hat linux enterprise 5 error

FWIW - in 10g there are scripts that will run a pre-install package check. Not sure if they're present in 9i tho....

That being said - the Oracle docs are pretty clear on these requirements too ;)

One site I find really useful:
http://www.idevelopment.info/

....he pretty much takes the Oracle docs, removes all the double- and triple-speak, and makes it so humans can understand the installation in a concise manner.

Good luck!
DV-LN
Z.K.
Frequent Advisor

Re: Install Oracle 9i on Red hat linux enterprise 5 error

Thank you all.
Still hang there.
I'll try to install Oracle10g instead to see if I can make it this time.
The site D.V. supplied is quite good.
Thanks!
Don Vanco - Linux Ninja
Regular Advisor

Re: Install Oracle 9i on Red hat linux enterprise 5 error

I'm surprised that just installing the "Legacy Application Support" package group didn't resolve your issue. If you can run 10g, that's great - but it won't change the reliance on that package group.

Did you try:
up2date -i "@ Legacy Application Support"

?

Don
Don Vanco - Linux Ninja
Regular Advisor

Re: Install Oracle 9i on Red hat linux enterprise 5 error

Sorry - I spaced that you are on RHEL 5 - it's
yum groupinstall

...not sure of the group name - you may have to list to see.....
yum grouplist

Don
emha_1
Valued Contributor

Re: Install Oracle 9i on Red hat linux enterprise 5 error

if you are current with libraries, look for log files in /tmp/OraInstall* and $ORACLE_HOME/OraInventory and check what errors they reports. I suppose there will be a java exception (oracle install packages typicaly has such kind of problems...). if so, try to change JRE pointer in oraparam.ini from oracle's JRE to the one you have installed on the system.


emha.
Don Vanco - Linux Ninja
Regular Advisor

Re: Install Oracle 9i on Red hat linux enterprise 5 error

emha -

Is that a typical issue?

Red Hat, by default, does not install JAVA - you have to pull it from the supplemental or yum it in. I've always used Oracle's default install w/o issue - but then I'm only doing a couple installs a year...

DV
emha_1
Valued Contributor

Re: Install Oracle 9i on Red hat linux enterprise 5 error

from my experience yes.

with couple of recent months I installed on RHEL4 DBs 9201+patch9208, 10201 - no one worked with suplied JRE.

the same experience I have from Tru64 environment...


emha.