Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Installation of Oracle 9iR2 fails on HP/UX 11.0 64bit

Stroppolo Andrea
Occasional Visitor

Installation of Oracle 9iR2 fails on HP/UX 11.0 64bit

Hello everybody.

I am testing installation of 9iR2 on our dev environment... everything _should_ be ok, since on the same machine I already installed 8.1.7 and 9iR1
The hardware is an L2000 with 8GB ram

However I cannot install this new release.
It fails with this error:

> dcov02:/oraoem/CD920/cd1$>Initializing Java Virtual Machine from
> /oraoem/temp/OraInstall2002-07-16_05-02-55PM/jre/bin/java. Please wait...
> Exception in thread "main" java.lang.UnsatisfiedLinkError:
> /oraoem/temp/OraInstall2002-07-16_05-02-55PM/jre/lib/PA_RISC2.0/libmawt.sl:
> No such file or directory
> at java.lang.ClassLoader$NativeLibrary.load(Native Method)
> at java.lang.ClassLoader.loadLibrary0(Unknown Source)
> at java.lang.ClassLoader.loadLibrary(Unknown Source)
> at java.lang.Runtime.loadLibrary0(Unknown Source)
> at java.lang.System.loadLibrary(Unknown Source)
> at sun.security.action.LoadLibraryAction.run(Unknown Source)
> at java.security.AccessController.doPrivileged(Native Method)
> at java.awt.Toolkit.loadLibraries(Toolkit.java:1073)
> at java.awt.Toolkit.(Toolkit.java:1117)
> at java.awt.Component.(Component.java:406)
> at oracle.sysman.oii.oiic.OiicInstaller.main(OiicInstaller.java:593)
>


Did anyone had the same issue?


Regards,
Andrea
4 REPLIES

Re: Installation of Oracle 9iR2 fails on HP/UX 11.0 64bit

Dear Andrea,

Based on Metalink information, your error occured probably caused by your existing JDK version. Its version must be 1.3.1.02.
BTW, I attach a scripts for you to check your existing HP-UX configuration before install your Oracle. Follow these steps to download and run the script:

1. Change the name of the script to InstallPrep.sh
2. Ftp the InstallPrep.sh script (in ascii format) to the Unix system that you will be installing the Oracle DataServer on.
3. Change the permissions of the script to execute for the user running the script:
chmod 777 InstallPrep.sh
4. Log in as the user that will be installing the Oracle software.
5. Copy the InstallPrep.sh script to the /tmp directory and run it from this location.
6. Answer the first few questions, the output from the script will be written to /tmp/Oracle_PreInstall_Report
7. Resolve any problems found in /tmp/Oracle_PreInstall_Report and then install the Oracle DataServer software.

Hope this useful.

Regards,
Doni
Stroppolo Andrea
Occasional Visitor

Re: Installation of Oracle 9iR2 fails on HP/UX 11.0 64bit

I have been out of office... sorry for being late...

The issue was in the packaging of the cd set: it seems that there are different packages:
v1->May02 is wrong, v3->Jun02 works fine.

Thanks!!!
andrea
Robert Groenemans
Occasional Contributor

Re: Installation of Oracle 9iR2 fails on HP/UX 11.0 64bit

As we are going to install Oracle 9i Release 2 also on a L2000
running HPUX 11.0 and we have the MAY02 Oracle 9i Database Release 2
(9.2.0.1.0) CD Pack, I would like to now if you logged this case
at Metalink?
Stroppolo Andrea
Occasional Visitor

Re: Installation of Oracle 9iR2 fails on HP/UX 11.0 64bit

Hello, Robert

Yue, I logged the case.

I have been referenced this bug

<2430985>

Hope this helps

Andrea