Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

Installing Oracle 8.1.7.3 on HP-Ux 11.0

SOLVED
Go to solution
Emanuele Croci
Occasional Contributor

Installing Oracle 8.1.7.3 on HP-Ux 11.0

I installed the patches:

PHCO_25707
PHCO_23963
PHSS_24303

but the compilation of Oracle 8.1.7.3 crashes:
make -f ins_rdbms.mk install


The output is:

- Linking Oracle
rm -f /ORACLE/app/oracle/product/8.1.7/rdbms/lib/oracle

cc -Wl,+s -Wl,+n -o /ORACLE/app/oracle/product/8.1.7/rdbms/lib/oracle .................
....
....
....

/usr/ccs/bin/ld: Unsatisfied symbols:
skgxntrace (first referenced in /ORACLE/app/oracle/product/8.1.7/lib/libgeneric8.a(kgxgi.o)) (code)
*** Error exit code 1

Stop.
*** Error exit code 1

Stop.


Can someone help me?


Emanuele
2 REPLIES
T G Manikandan
Honored Contributor
Solution

Re: Installing Oracle 8.1.7.3 on HP-Ux 11.0

fact: Oracle Server - Standard Edition 8.1.7.3
fact: HP 9000 Series HP-UX (64-bit)
symptom: Relink fails during installation
symptom: Unsatisfied symbols
symptom: /usr/ccs/bin/ld: Unsatisfied symbols: skgxntrace (first referenced
in /oracle/product/8.1.7/lib/libgeneric8.a(kgxgi.o)) (code)
change: Applied patchset 8.1.7.3
cause: Applying the 64-bit patchset release onto a 32-bit installation of
Oracle



fix:

There are two 8.1.7.3 patchsets for HP-UX:

- ID:1335298 Patchset::2189751 for Oracle 32-bit
- ID:1335296 Patchset::2189751 for Oracle 64-bit

Choose "ID:1335298" for a 32-bit installation of Oracle, even though
the HP-UX is 64-bit.


THis is the patch set you need to download.
Download this from the oracle web-site and install it to fix the error.



ID:1335296 Patchset::2189751 README
8.1.7.3 PATCH SET FOR ORACLE DATA SERVER
Product:Oracle Database
Platform:HP 9000 Series HP-UX 64bit
Language:American English

THanks
Yogeeraj_1
Honored Contributor

Re: Installing Oracle 8.1.7.3 on HP-Ux 11.0

hi emanuele,

Make sure you went through all the preinstallation and any readmes. You may wish to contact Oracle Support. The remarks from the previous post are valid.

Hope you don't mind my remarks.

You should install the latest available patchset too. i.e. 8.1.7.4

I have had several problems (ORA-600) with both 8.1.7.0 and 8.1.7.3.

8.1.7.4 have several bug fixes from 8.1.7.3.

(no additional patches required as far as what i know)

hope this helps.

Best Regards
Yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)