General
cancel
Showing results for 
Search instead for 
Did you mean: 

Installing RedHat 7.2 on NetServer LX

Grant Kenning
Occasional Visitor

Installing RedHat 7.2 on NetServer LX

I have installed RedHat 7.2 on my recently acquired HP NetServer LX machine and have struck problems with the NIC and configuring Xfree86.

The server has 4 x 200Mhz processors, 512Mb RAM and 7 x 9Gb harddrives.

The installation went normally except the original NIC (SMC EISA card) would not be discovered. I subsequently replaced this with a PCI eep100 type card and the new card was discovered and configured OK but gives the following error when trying to bring up the interface:
SIOGIFFLAG: no such device. What does this mean?

Another problem is with the video card (Cirrus CL-G5424). SuperProbe reports the correct card type but I cannot get it to work properly with Xconfigurator. I have tried various generic monitor settings to no avail.

To finish of I have noticed the folloing messages on boot and in the messages log:
PCI: Cannot allocate resource region [0-5] of device 00:0f.0
What does this mean?

I am experienced at installing RedHat on your average desktop machine but this is the first attempt at any machine that resembles a small office building. All pointers are greatfully received.

regards
gk
3 REPLIES
Kodjo Agbenu
Honored Contributor

Re: Installing RedHat 7.2 on NetServer LX

Hello Grant,

Please post the following information :

=> lspci -v
=> cat /proc/isapnp (if it doesn't exist, try pnpdump)
=> /etc/X11/XFree86 or XFree86-4

Good luck.

Kodjo
Learn and explain...
Grant Kenning
Occasional Visitor

Re: Installing RedHat 7.2 on NetServer LX

Hi Kodjo
Sorry about the delay in answering your relpy. I have rebuilt the box a couple of times since posting this query as I wanted to reconfigure the Raid setup and partly because I wanted the practice. I have included the output from the commands you have suggested in the txt file. Have removed all unnecessary cards from the machine and now have just the NIC in slot P3 and the raid adapter in P6, no EISA cards.

I ended up with the same result each time regarding the video card. This surprizes me as I have successfully set thes cards up on older desktop machines with earlier kernel versions. If you can shed any more light I will be much obliged.

Cheers
gk
Kodjo Agbenu
Honored Contributor

Re: Installing RedHat 7.2 on NetServer LX

Hello,

It seems that your graphic adapter (Cirrus Logic GD542x) is not supported with XFree86-4.x.
However, you can get it working with XFree86-3.3.6, but unaccelerated.

For further information :

http://www.xfree86.org/4.2.0/Status9.html#9

I would suggest you to downgrade your XFree86 version.

According to your ethernet adapter, if the eepro100 driver is not working so well, try the e100 driver (modprobe e100). To make it automatically loaded, add in your /etc/modules.conf :

alias eth0 e100

then type "depmod -a" to rebuild the module dependency graph.

Good luck.

Kodjo
Learn and explain...