General
cancel
Showing results for 
Search instead for 
Did you mean: 

Installing SuSE Enterprise Server 9 on DL360

Prem Ratnam
Occasional Contributor

Installing SuSE Enterprise Server 9 on DL360

I have a DL360 server with a P600 array (with 2 SAS 72 GB drives, mirrored in a RAID 1 configuration). We're trying to install
SuSE Linux 9 on it, but the installer won't recognize the hard drives.

I see that there are drivers available on the HP website
(cpq_cciss-2.6.10-11.sles9.x86_64.rpm), but I cannot determine how to install this when I have no OS installed. I also found the file
cpq_cciss-2.6.10-11.sles9.x86_64.dd - which I burnt to CD and tried to load it as a driver under the SuSE installation process,but the installer does not recognize this as a valid driver. Some of the support docs talk about supplying the driver through a floppy, but my DL360 has no floppy drives.

I can see from the support matrix that the DL360 is certified for SuSE Linux 9. How can I get the disk array recognized so that I can proceed with the installation?

Thanks,
Prem
2 REPLIES
Ivan Ferreira
Honored Contributor

Re: Installing SuSE Enterprise Server 9 on DL360

You need to create the disk image cpq_cciss-2.6.10-11.sles9.x86_64.dd using the dd command or rawrite. This file will be expanded to the neccesary modules. If you don't have a floppy, you can use a USB pen drive:

dd if=cpq_cciss-2.6.10-11.sles9.x86_64.dd of=/dev/sd1

Where is your pen drive and depends of the number of scsi disks devices installed. Specify this device as the driver disk.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Prem Ratnam
Occasional Contributor

Re: Installing SuSE Enterprise Server 9 on DL360

I tried the driver update way using an USB floppy drive - didn't work. The installer did seem to read the update file OK, but later on in the install, the disk array was still not visible. Not sure if this is due to version differences between the kernel and the driver. My kernel is 2.6.5.7, and I tried the update files for 2.6.2, 2.6.4, 2.6.6 and 2.6.10 (couldn't find a driver for 2.6.5 from the HP website)

I've since found that SuSE 9 Service Pack 3 has the correct drivers for the P600 array. I tried it, and it works.