General
cancel
Showing results for 
Search instead for 
Did you mean: 

Issue in displaying Turkish Character on HP_UX

want2bsm1
Occasional Advisor

Issue in displaying Turkish Character on HP_UX

Hi,

The Unix version, I am using is

HPUXBaseAux B.11.23.0505 HP-UX Base OS

Following are the setting of locale and NLS_LANG at client side :

>>locale charmap
"utf8.cm"

>> echo $LC_ALL
en_US.utf8

echo $NLS_LANG
AMERICAN_AMERICA.UTF8

The settings with UTF-8 are working perfectly fine on solaris.However, package en_US.UTF-8 is not on HP and thus we had to change to en_US.utf8.

I am not sure what might be causing the issue.One more thing is at Oracle database server side, I see one another differnce, though i m not sure if that might be causing the same thing to not work on HP.

On solaris :

NLS_CHARACTERSET is WE8MSWIN1252

On HP :

NLS_CHARACTERSET is WE8ISO8859P1

This is very Urgent.Any Help is greatly appreciated.

Thanks

9 REPLIES
Dennis Handly
Acclaimed Contributor

Re: Issue in displaying Turkish Character on HP_UX

>echo $LC_ALL -> en_US.utf8

Are you sure you don't want some Turkish locale?
want2bsm1
Occasional Advisor

Re: Issue in displaying Turkish Character on HP_UX

Thanks for the response Dennis.

Since, I have to support a mixture of languages, Turkish and English here, I donot know If i can use Only Turkish locale.

However, I did give it a try but application fails to start.

On Solaris, LC_ALL setting to en_US.UTF-8, is working fine.

And when i say fine, that means, The application is able to support Turkish characters along with English characters, and thus store them in database and display them correctly with a windows client and also web client.

However, with HP, and above setting all i get is replacement characters, which Oracle automatically replaces.So what i get is a junk of ?? and some other incomprehensible characters.

Please let me know , If you want some further information.

Also, to add On Solaris, RDBMS was 11.0.2.6 while HP application is talking to 10.0.2 and as i had mentioned earlier, the NLS_CHARACTERSET at server side are also different.

Again, Thanks so lot for reply.
Dennis Handly
Acclaimed Contributor

Re: Issue in displaying Turkish Character on HP_UX

>I do not know if i can use Only Turkish locale.

You could try it.
want2bsm1
Occasional Advisor

Re: Issue in displaying Turkish Character on HP_UX

I did tried Dennis, but my application fails to start. :( I also tried with univ.utf8 locale, but again my application does not starts.

Along with above, I am alos doing two other things, did not mentioned as they do not seem to be platform dependent.

Have added these two to classpath

WL_HOME/server/ext/jdbc/oracle/10g/orai18n.jar
$ORACLE_HOME/jlib/orai18n.jar

And started the java applications in application including weblogic, with :

-Dfile.encoding=UTF-8


Do not know, what I am missing here and what actually is different on HP, if it works like butter on Solaris.





skt_skt
Honored Contributor

Re: Issue in displaying Turkish Character on HP_UX

want2bsm1
Occasional Advisor

Re: Issue in displaying Turkish Character on HP_UX

Thanks for referring me to the Gloabalization URL.That would definitely help me in atleast providing you with more correct data.


I want to store some turkish characters, for example Ä Ã§Ä±Ã¶Å Ã¼, and Its stored as ¿ç¿ö¿ü.

While in sqlplus, I am not able to copy the above turkish exactly and thus it gets pasted as .g.v.|.

However with this query,

SQL > select DUMP('.g.v.|',1016) FROM ;

OUTPUT :

Typ=96 Len=6 CharacterSet=WE8ISO8859P1: 2e,67,2e,76,2e,7c

My issue gets reolved in Solaris box, with 11G database setting and charset set to WE8MSWIN1252.All the details provided above.

Please let me know, If u want some more information.

Thanks so lot.
want2bsm1
Occasional Advisor

Re: Issue in displaying Turkish Character on HP_UX

Hi,

There has been an update on the issue.

when I changed the Database to 11G, with

NLS_CHARACTERSET=WE8MSWIN1252
NLS_NCHAR_CHARACTERSET=AL16UTF16
NLS_TERRITORY=AMERICA
NLS_LANGUAGE=AMERICAN

I am now able to get , Ä Ã IÃ Å Ã as GÃ IÃ SÃ . However, The G and S should be like Ä and Å .

Is it because, my database characterset, still cannot support ALL turkish characters ? Which Database character set support ALL Turkish characters ?

Please let me know, If you want any further information.

Thanks.
skt_skt
Honored Contributor

Re: Issue in displaying Turkish Character on HP_UX

Did u check with Oracle Support?
want2bsm1
Occasional Advisor

Re: Issue in displaying Turkish Character on HP_UX

Yep, started one there as well.

Thanks for all help.

Will update in case get any solution.