General
cancel
Showing results for 
Search instead for 
Did you mean: 

Issue with installing PDF::API2 (0.73) version on HP-ux

vijayv
Occasional Contributor

Issue with installing PDF::API2 (0.73) version on HP-ux

Hi ,

I was trying to use PDF::FromHTML module in my perl script.

PDF::API2 is a dependent module to use this.SO i installed it.

I am gettting the below error if i am checking for the module


# perl -MPDF::API2 -e1
Can't load '/opt/perl_32/lib/5.8.7/IA64.ARCHREV_0-thread-multi/auto/Storable/Storable.so' for module Storable: Exec format error at /opt/perl_32/lib/5.8.7/IA64.ARCHREV_0-thread-multi/DynaLoader.pm line 230.
at /opt/perl_32/lib/5.8.7/Unicode/UCD.pm line 8
Compilation failed in require at /opt/perl_32/lib/5.8.7/Unicode/UCD.pm line 8.
BEGIN failed--compilation aborted at /opt/perl_32/lib/5.8.7/Unicode/UCD.pm line 8.
Compilation failed in require at /opt/perl_32/lib/site_perl/5.8.7/PDF/API2/Resource/Font/BdFont.pm line 45.
BEGIN failed--compilation aborted at /opt/perl_32/lib/site_perl/5.8.7/PDF/API2/Resource/Font/BdFont.pm line 45.
Compilation failed in require at /opt/perl_32/lib/site_perl/5.8.7/PDF/API2.pm line 67.
BEGIN failed--compilation aborted at /opt/perl_32/lib/site_perl/5.8.7/PDF/API2.pm line 67.
Compilation failed in require.
BEGIN failed--compilation aborted.

Can somebody help me in resolving this. Thanks in advance

Vijay




1 REPLY
vijayv
Occasional Contributor

Re: Issue with installing PDF::API2 (0.73) version on HP-ux


Hi , the issues was with the permission for opt/perl_32/lib/5.8.7/IA64.ARCHREV_0-thread-multi/auto/Storable/Storable.so

I fixed it. Now i have another issue :)

Now i included use PDF::FromHTML in my perl script.


I am getting the below error

cannot find font '' ... at /opt/perl_32/lib/site_perl/5.8.7/PDF/API2/Resource/CIDFont/TrueType/FontFile.pm line 464.

I am not able to figureout this issue. Can somebody let me know if u faced this issue !!

Thanks,
Vijay