Issues Running Linux on HP Pavilion 310n

Theodore Jay Allen
Occasional Advisor

Issues Running Linux on HP Pavilion 310n

I am having video issues getting any Linux variant Live CD to run on an HP Pavilion 310n with the Intel 810e chipset and onboard video.

I have also installed a PCI-based GeForce FX5200 without success.

The PhoenixBIOS v3.06 does not give the ability to disable the onboard video even though the field-specific help indicates that you can select a disable option. However, the only options for the primary video adapter are PCI and AGP. This system does not have any AGP slots. Thus, even when using the onboard video, the primary adapter in the BIOS has to be set to either PCI or AGP.

Additionally, the amount of RAM to be assigned to the onboard video must be set to 512KB or 1MB. There is not option to set it to 0 (zero).

The GeForce adapater I installed has a DVI-I output and I have used a DVI-I to VGA adapter to convert it for use with a VGA monitor. However, when the LiveCD boots to the point of attempting to bring up the X server, I get a "frequency out of range" error message on the monitor. Depending on which monitor I use (both monitors I tested with are VGA), the results are slightly different, but only because the older of the two monitors allows me to save the frequency settings it is receiving as a user mode setting and tries to continue on. However, the display is completely garbled. The message indicates various resolution and frequency combination settings on the older monitor.

I have tried selecting lower resolution settings and even booting in video failsafe mode with no success. I can boot up in text or VESA mode, obtain a login prompt, and access the shell. In this mode, if I run "sax2" on openSUSE to try to configure the X server, it eventually errors out and from the messages in the logs looks like it is still trying to deal with the onboard Intel video instead of the GeForce adapter.

At first I thought the KVM switch I was going through might be confusing things, but even with it out of the mix, the issue remains.

The onboard video works fine with Windows XP but not with any of the Linux variants I have tried (openSUSE, Fedora, Knoppix, Ubuntu).

Any assistance is greatly appreciated.

Best Regards,