cancel
Showing results for 
Search instead for 
Did you mean: 

Japanese LANG set on HPUX 11.11

Pnaidu
Frequent Advisor

Japanese LANG set on HPUX 11.11

Hi,
I can't view Japanese characters on CDE instead some junk characters displaying.
Please assist me in setting the Lang.

$ echo $LANG
ja_JP.utf8
$ locale -a |grep -i jp
ja_JP.SJIS
ja_JP.eucJP
ja_JP.kana8
ja_JP.utf8

Following are the bundles, I have:
CDE-Japanese B.11.11.0412 Japanese CDE Environment
International.JAPANESE B.11.11 JAPANESE
20 REPLIES
Robert-Jan Goossens
Honored Contributor

Re: Japanese LANG set on HPUX 11.11

Hi,

Have a look at this doc.

http://docs.hp.com/en/5991-5907/ch01s03.html

Regards,
Robert-Jan
Pnaidu
Frequent Advisor

Re: Japanese LANG set on HPUX 11.11

Hi,
I followed the URL and found my system don't have these bundles:
HPUXLocales
HPUXEssential
HPUXExtns-Jpn
I don't see these bundles available on OS media.
Thanks, P.Naidu
Avinash20
Honored Contributor

Re: Japanese LANG set on HPUX 11.11

It will be available in DVD-1
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Avinash20
Honored Contributor

Re: Japanese LANG set on HPUX 11.11

Sorry. Let me check if its available for 11.11 media. Its available in 11.31 media, but let me go via 11.11 media
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Avinash20
Honored Contributor

Re: Japanese LANG set on HPUX 11.11

http://docs.hp.com/en/5991-5907/ch01s02.html
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Pnaidu
Frequent Advisor

Re: Japanese LANG set on HPUX 11.11

Avinash,
I can't find HPUXLocales/HPUXExtns-Jpn on 11.11 OS media (Dec2006).

Where else can I get these bundles??

Thanks, P.Naidu
Avinash20
Honored Contributor

Re: Japanese LANG set on HPUX 11.11

My friend, the documents which we were referring is for 11.31, but you are having 11.11

## Probably we need to start again
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Robert-Jan Goossens
Honored Contributor

Re: Japanese LANG set on HPUX 11.11

url to the 11.11 cde documentation.

http://docs.hp.com/en/5971-2271/ch01s03.html
Avinash20
Honored Contributor

Re: Japanese LANG set on HPUX 11.11

I could find this doc: http://docs.hp.com/en/5971-2271/ch01s02.html
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Avinash20
Honored Contributor

Re: Japanese LANG set on HPUX 11.11

Oops.. Robert .. grt !!
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Pnaidu
Frequent Advisor

Re: Japanese LANG set on HPUX 11.11

No sucess yet.
Manual says to set LANG and run:
eval `/usr/dt/bin/dtimsstart -env`

I'm still getting junk characters..
Any Suggestion please?

Thanks, P.Naidu
Avinash20
Honored Contributor

Re: Japanese LANG set on HPUX 11.11

Let me check and try out in our test server
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Shinji Teragaito_1
Respected Contributor

Re: Japanese LANG set on HPUX 11.11

Hi,

It's very easy to select Japanese SJIS or EUC.JP from the Option menu at the CDE login. LANG and XMODIFIERS will be configured correctly as you select.

Otherwise, if you are already seeing the CDE X session, how about this ?

% env LANG=ja_JP.eucJP hpterm -fn "-*-14-*:"

Afterwards, you can confirm if the Japanese characters are correctly displayed by issuing 'date'.

Best Regards,

Shinji
Shinji Teragaito_1
Respected Contributor

Re: Japanese LANG set on HPUX 11.11

Hi,

dtimsstart is automatically launched after selecting the Japanese
locale at the CDE login menu.

If you want to enter Japanese characters through XIMS (X Input
Method Server), it's a good start to select your favorable XIMS from
the selection menu displayed by dtimsstart. But you need to have
much more learning time to use XJIM, ATOK, or VJE-Gamma :-)

If you want to view the file content encoded with SJIS, EUC, JIS or
UTF8 encoding in your terminal emulator, you don't spend your time
to launch dtimsstart. My previous message should work. Don't forget
to use iconv(1).

Shinji
Pnaidu
Frequent Advisor

Re: Japanese LANG set on HPUX 11.11

Shinji,
Thanks for the reply. Indeed I've tried setting different japanese locales but no success.
Am I missing any packages or patches related to Japanese locale on my HPUX 11.11?

Thanks, P.Naidu
Shinji Teragaito_1
Respected Contributor

Re: Japanese LANG set on HPUX 11.11

Please let me check your status.

1. Are you sitting in front of the 11.11 server ? Or do you want to
access the 11.11 server through PC running with X server or any UNIX
console running with X server ?

2. Can you specify one of Japanese locales from the Option menu at the
CDE login ?

Options -> Languages -> ja_JP.SJIS or ja_jp.eucJP

3. Do you have the japanese fonts on your X server ? What kind of
results do you have when issuing the following command ?

% xlsfonts -fn '*jis*'

I can view the Japanese characters correctly when accessing 11.11
through Cygwin/X and Reflection X running on Windows XP.

Best Regards,

Shinji
Pnaidu
Frequent Advisor

Re: Japanese LANG set on HPUX 11.11

Shinji,

1)I'm running X-manager1.3.9 , can access console also.

2) I did select Japanese locales from CDE login menu but it shows junk characters.

3)# xlsfonts -fn '*jis*'
-misc-fixed-medium-r-normal--0-0-75-75-c-0-jisx0201.1976-0
-misc-fixed-medium-r-normal--14-130-75-75-c-70-jisx0201.1976-0
-sony-fixed-medium-r-normal--0-0-100-100-c-0-jisx0201.1976-0
-sony-fixed-medium-r-normal--16-120-100-100-c-80-jisx0201.1976-0
-sony-fixed-medium-r-normal--16-150-75-75-c-80-jisx0201.1976-0
-sony-fixed-medium-r-normal--24-170-100-100-c-120-jisx0201.1976-0
-sony-fixed-medium-r-normal--24-230-75-75-c-120-jisx0201.1976-0


Thanks, P.Naidu
Shinji Teragaito_1
Respected Contributor

Re: Japanese LANG set on HPUX 11.11

Hi,

You have only JIS X 0201 fonts. You need to have JIS X 0208 fonts on
your X server to display Kanji (multi-byte) characters.

NOTE: you can confirm what kind of characters are defined in the
fonts you have:
% xfd -fn -misc-fixed-medium-r-normal--0-0-75-75-c-0-jisx0201.1976-0

FYI, here's my results on Cygwin/X:

% xlsfonts -fn '*jis*'
-jis-fixed-medium-r-normal--0-0-75-75-c-0-jisx0208.1983-0
-jis-fixed-medium-r-normal--16-110-100-100-c-160-jisx0208.1983-0
-jis-fixed-medium-r-normal--16-150-75-75-c-160-jisx0208.1983-0
-jis-fixed-medium-r-normal--24-170-100-100-c-240-jisx0208.1983-0
-jis-fixed-medium-r-normal--24-230-75-75-c-240-jisx0208.1983-0
-misc-fixed-medium-r-normal--0-0-75-75-c-0-jisx0201.1976-0
-misc-fixed-medium-r-normal--0-0-75-75-c-0-jisx0208.1983-0
-misc-fixed-medium-r-normal--14-130-75-75-c-140-jisx0208.1983-0
-misc-fixed-medium-r-normal--14-130-75-75-c-70-jisx0201.1976-0
%

Shinji
Pnaidu
Frequent Advisor

Re: Japanese LANG set on HPUX 11.11

Shinji,

Problem is resolved now, after installing xming xserver.
X-manager was not supporting Japanese Character sets.

ArigatÅ (ã ã ã ã ¨ã ),
P.Naidu
Shinji Teragaito_1
Respected Contributor

Re: Japanese LANG set on HPUX 11.11

Hi P.Naidu,

Dou Itashimashite.

Thank you for your updates and introducing Xming to us. I'll try to use Xming instead of Cygwin/X.

Shinji