General
cancel
Showing results for 
Search instead for 
Did you mean: 

Japanese characters in CDE (HP-UX 11.31)

goonzie
Occasional Visitor

Japanese characters in CDE (HP-UX 11.31)

I have next environment:

locale -a | grep -i \jp
ja_JP.SJIS
ja_JP.eucJP
ja_JP.kana8
ja_JP.utf8

HPUXExtns-Jpn B.11.31 Japanese font, input methods and printer extensions,
and CDE-Japanese B.11.31 Japanese CDE Environment is installed

I define LANG=ja_JP.SJIS in .dtprofile, but when I try to login to xcdmp session I don't see Japanese sysmbols, only unredable.

How can I check that the x-server knows about japanese fonts?
7 REPLIES
OldSchool
Honored Contributor
Shinji Teragaito_1
Respected Contributor

Re: Japanese characters in CDE (HP-UX 11.31)

Are you using X-Server on your PC ? If so, you should confirm
whether X-Server on your PC has Japanese fonts.

http://forums.itrc.hp.com/service/forums/questionanswer.do?threadId=1304139
goonzie
Occasional Visitor

Re: Japanese characters in CDE (HP-UX 11.31)

I try
xlsfonts -fn '*jis*'
xlsfonts: pattern "*jis*" unmatched

but ls /usr/dt/config/xfonts/
C ja_JP.eucJP zh_CN.gb18030 zh_HK.hkbig5 zh_TW.ccdc
ja_JP.SJIS ko_KR.eucKR zh_CN.hp15CN zh_TW.big5 zh_TW.eucTW

here is imslog:
cat /home/japan/.dt/ims/imslog
[09/02/09 10:21:24] dtimsstart: 'xjim' started for my-windows-pc.domain.name:0
Warning: Missing charsets in String to FontSet conversion
Warning: Missing charsets in String to FontSet conversion
XJIM: cannot create FontSet from '-hp-gothic-medium-r-normal--16-*-c-*' -- Exit
[09/02/09 10:21:25] dtimsstart: 'xjim' aborted.
goonzie
Occasional Visitor

Re: Japanese characters in CDE (HP-UX 11.31)

I also try to connect from Japanese Windows using xming, but I have the same suit
goonzie
Occasional Visitor

Re: Japanese characters in CDE (HP-UX 11.31)

I have a troubles in console also (see attach)
LANG=ja_JP.eucJP

Shinji Teragaito_1
Respected Contributor

Re: Japanese characters in CDE (HP-UX 11.31)

You need Japanese fonts on your X Server.

> I have a troubles in console also (see attach)
> LANG=ja_JP.eucJP

You should set LANG=ja_JP.SJIS.
goonzie
Occasional Visitor

Re: Japanese characters in CDE (HP-UX 11.31)

Many thanks Shinji!
Now I resolv my problem, oh this sly back to front technology x-server. I just install Japanese fonts on my windows workstation with X-server and now I see good redable Japanese symbols