General
cancel
Showing results for 
Search instead for 
Did you mean: 

Java 8 JNI Unsatisfied Link error after upgrading from Java 6

 
asoghier
Occasional Visitor

Java 8 JNI Unsatisfied Link error after upgrading from Java 6

Hi,

We upgraded Java from 1.6 to 1.8

We have a part in the code where we use C libs called via System.loadlibrary()

The code compiled without any issue.

However, during runtime we are getting this error

SEVERE: Could not connect to middleware.  java.lang.Exception: Error while executing  - createMssRequestjava.lang.UnsatisfiedLinkError: lib****.sl: 'lib***.sl' is not a valid load module: Bad magic number

Reading online everyone suggests that this is a 32 bit Vs 64 bit issue.

We tried adding the +DD64 in aCC to compile the C code and also -d64 when compiling and running the Java code.

Has anyone come across the same issue and do you have any suggestions on how we can resolve this?

 

Thanks,

1 REPLY 1
mbarnwal
Occasional Advisor

Re: Java 8 JNI Unsatisfied Link error after upgrading from Java 6

Hi,

This requires deeper analysis. I would suggest opening a ticket with HPE.

Regards

Manish

 

I am a HPE Employee