cancel
Showing results for 
Search instead for 
Did you mean: 

KDE/klauncher and dtterm

Runar Jørgensen
Frequent Advisor

KDE/klauncher and dtterm


Greetings

This is more of a KDE question. I'm curious about klauncher.
I've replace good 'ol CDE with KDE, but kept e.g. dtterm.
If I start dtterm with options from klaunhcer (in the panel),
I get errors. If I start from xterm rxvt or whatever commandline
window I'm ok.

I try this commandline:

/usr/dt/bin/dtterm +kshMode -fn "-dt-interface user-medium-r-normal-s sans-12-120-
72-72-m-70-iso8859-1"&

In klauncher I get these errors:

kio (KLauncher): setLaunchEnv KDE_INITIAL_DESKTOP=1
kio (KLauncher): KLauncher: Got start_service_by_desktop_path('/home/runar/.kde/sh
are/applnk/System/Dtterm.desktop', ...)
kdeinit: Got SETENV 'KDE_INITIAL_DESKTOP=1' from klauncher.
KInit: Got EXEC '/usr/dt/bin/dtterm' from klauncher.
Could not dlopen library /usr/dt/bin/dtterm: (null)
Could not load library! Trying exec....
kio (KLauncher): /usr/dt/bin/dtterm (pid 2823) up and running.
KLauncher doing clientStarted(`/usr/dt/bin/dtterm')
dtterm: bad command line option "user-medium-r-normal-s"

usage: dtterm [-/+132] [-/+aw] [-/+bs] [-display displayname]
[-e command args] [-fb fontset] [-fn fontset] [-geometry geom] [-help]
[-/+iconic] [-/+j] [-/+kshMode] [-/+l] [-lf filename] [-/+ls] [-/+map]
[-/+mb] [-ms color] [-n string] [-name string] [-nb distance] [-/+rw]
[-/+sb] [-/+sf] [-sl number[s]] [-ti name] [-title string] [-tm string]
[-tn name] [-usage] [-/+vb] [-xrm resourcestring] [-C] [-Sxxd] [-Sxxx.d]

Type "dtterm -help" for a full description.

kdeinit: PID 2823 terminated.

Here's a dump of /home/runar/.kde/share/applnk/System/Dtterm.desktop

$ cat Dtterm.desktop
[Desktop Entry]
Comment=
Comment[C]=
Exec=/usr/dt/bin/dtterm +kshMode -fn "-dt-interface user-medium-r-normal-s sans-
12-120-72-72-m-70-iso8859-1"
Icon=/opt/share/icons/Dtxterm.l.xpm
MimeType=
Name=Dtterm
Name[C]=Dtterm
Path=
ServiceTypes=
SwallowExec=
SwallowTitle=
Terminal=false
TerminalOptions=
Type=Application
X-KDE-SubstituteUID=false
X-KDE-Username=

Changing from " " to ' ' doe no good either.
Comments anyone?

Regards,
Runar J??rgensen
7 REPLIES
Jarle_1
Occasional Advisor

Re: KDE/klauncher and dtterm

Heisann Runar,

maybe you need to put the options to your exec in separate parameters.

Rgds Jarl
Your mouse has changed position Windows Nt must rebboot to activate the change. Reboot NOW ?
Jarle Bjorgeengen
Trusted Contributor

Re: KDE/klauncher and dtterm

Try this to work around it.

Exec=sh -c '/usr/dt/bin/dtterm +kshMode -fn "-dt-interface user-medium-r-normal-s sans-
12-120-72-72-m-70-iso8859-1"'

Rgds Jarle
Runar Jørgensen
Frequent Advisor

Re: KDE/klauncher and dtterm

Hi jarle

Thanks for your reply.

Unfortunately wrapping with a shell doesn't do the trick. It starts the dtterm ok, but forgets about the options. So the whole point of giving options is gone. :-)

I'm open for even more suggestions.

Regards,
Runar J??rgensen
Jarle Bjorgeengen
Trusted Contributor

Re: KDE/klauncher and dtterm

Try,

Exec=/usr/dt/bin/dtterm +kshMode -fn -dt-interface-user-medium-r-normal-s sans-12-120-72-72-m-70-iso8859-1

Jarle
Jarle Bjorgeengen
Trusted Contributor

Re: KDE/klauncher and dtterm

Sorry disregard the last.

Try,

Exec=/usr/dt/bin/dtterm +kshMode -fn -dt-interface-user-medium-r-normal-s-sans-12-120-72-72-m-70-iso8859-1

Jarle
Runar Jørgensen
Frequent Advisor

Re: KDE/klauncher and dtterm

Hi Jarle

Well, again I do get a dtterm, but not the font I want. Unfortunately.
Actually the font is indeed specified with white spaces, so just replaing white spaces with hyphens doesn't do the trick.

However, I've tried something that worked somewhat. I'll get back here with details. Just need to check some stuff first. "Skal bare ..." :-)

Regards,
Runar J??rgensen
Runar Jørgensen
Frequent Advisor

Re: KDE/klauncher and dtterm

Greetings

I've got it!
Here's a summary for anyone who wants:

Couldn't figure out how to use fonts vi the command line option.
Defaulting to the standard way of specifying Xserver resources.
Namely .Xdefaults (in my case) or .Xresources (for others.

NB! NB! NB!
The catch is to use dtterm's special userFont resource for
specifying the font. :-( Using xterm standard font resource does
not give the expected result.

Here's the relevant part of my $HOME/.Xdefaults

Panel*userFont: -dt-interface user-medium-r-normal-s sans-12-*-72-72-*-*-iso8859-1

Here's the relevant part of $HOME/.kde/share/applnk/System/Dtterm.desktop
Exec=/usr/dt/bin/dtterm +kshMode -name Panel

Remeber to issue a

$ xrdb -merge ~/.Xdefaults

for changes in .Xdefaults to take effect.

That's it and that's all.
Thank's for the hints.