cancel
Showing results for 
Search instead for 
Did you mean: 

Kickstart

RobertClark
Occasional Contributor

Kickstart

Am new to kickstart file, using parallel am running image of isolinux

In isolinux.cfg file .I have specified path of ks.cfg.I created image by using this command

sudo mkisofs -o ../ks.iso -V 'RH9 Install' -b isolinux/isolinux.bin -c isolinux/boot.cat -no-emul-boot -boot-load-size 4 -boot-info-table -R -J -V -T .

When i boot it using parallel it say ks.cfg. Can u tell me how to specify path
for ks.cfg.

default ks
prompt 1
timeout 200
display boot.msg
F1 boot.msg
F2 options.msg
F3 general.msg
F4 param.msg
F5 rescue.msg
F7 snake.msg
label ks
kernel vmlinuz
append initrd=initrd.img ramdisk_size=8192 ks=file:/root/Desktop/isolinux/isolinux/ks.cfg
label linux
kernel vmlinuz
append initrd=initrd.img ramdisk_size=8192
label text
kernel vmlinuz
append initrd=initrd.img text ramdisk_size=8192
label expert
kernel vmlinuz
append expert initrd=initrd.img ramdisk_size=8192
label ks
kernel vmlinuz
append ks initrd=initrd.img ramdisk_size=8192
label lowres
kernel vmlinuz
append initrd=initrd.img lowres ramdisk_size=8192
label local
localboot 1
label memtest86
kernel memtest
append -
2 REPLIES
Stuart Browne
Honored Contributor

Re: Kickstart

If using a 'ks=' type of URL, it should be relative to the ISO image i.e. 'ks=cdrom:/ks.cfg' or 'ks=floppy'. The 'ks=file:/ks.cfg' type should only be used if the 'ks.cfg' is within the 'initrd' image.

See:

http://www.redhat.com/docs/manuals/linux/RHL-9-Manual/custom-guide/s1-kickstart2-startinginstall.html
One long-haired git at your service...
Matti_Kurkela
Honored Contributor

Re: Kickstart

Also, the "ks=..." option should be added to the "append" line. It should not be on its own line.

Where is the ks.cfg located in the CD-ROM?

If the ks.cfg is located in the top-level directory of the CD-ROM, the correct option would be "ks=cdrom:/ks.cfg".

If it's in the "isolinux" subdirectory, the correct option would be "ks=cdrom:/isolinux/ks.cfg".

MK
MK