Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

LVM not working on RedHat linux advance server 2.1

Bindumadhava.V
Frequent Advisor

LVM not working on RedHat linux advance server 2.1

Hi

I am getting following error after installing LVM on RH AdvServ 2.1....

[root@udc1 root]# vgscan
vgscan -- LVM driver/module not loaded?

Has anyone tried on this..?

Regards
Bindumadhava.

4 REPLIES
Alex_133
Advisor

Re: LVM not working on RedHat linux advance server 2.1

You will need to recompile the kernel to support LVM.
Vitaly Karasik_1
Honored Contributor

Re: LVM not working on RedHat linux advance server 2.1

RH AS 2.1 doesn't support LVM.

I hope, we will see LVM support in AS 3.0 this autumn.

I don't recommend you to apply LVM or other patches to AS kernel, because RH doesn't support custom kernels.

Vitaly.
Jarle Bjorgeengen
Trusted Contributor

Re: LVM not working on RedHat linux advance server 2.1

Hi,

If you buy ServicGuard for Linux you get LVM for AdvancedServer 2.1 bundled.

Serviceguard is only supported on Netserver and Proliant hardware though.

ServiceGuard applies patches, and builds a new kernel with LVM support.

You can get support for this solution through HP.

Rgds Jarle
HP Norway
Chris DePetro
Occasional Advisor

Re: LVM not working on RedHat linux advance server 2.1

Red Hat does not support LVM in AdvServer 2.1. Although I have it working without any problems. You can install the LVM rpm from a RH 7.3 CD, then recompile your kernel to support LVM. The rpm provides all of the necessary commands. I have had LVM running for a year now on AdvServer 2.1 without any issues. Hope this helps.