Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Linux Bad IRQ setting...

Joaquin Negron
Occasional Visitor

Linux Bad IRQ setting...

I have installed a ne2000 network card on my 8560 Pavilion which is recognized
by Corel Linux. But I get an error message (dmesg on Linux) that tells me that
the BIOS assigned IRQ 0 and it's not likely to work, which is the case. It also
tells me I have to change this setting in the BIOS. I have started the machine
hitting the F1 key to get into the BIOS (CMOS?), but I can't find where to make
this change. If anyone knows how to solve this, your help is greatly
appreciated..
7 REPLIES
Patrick Watts_1
Frequent Advisor

Re: Linux Bad IRQ setting...

Joaquin,

I take it that this is a plug & play card. It does not appear that you are
able to assign individual irqs/slots in the 8560 BIOS. The easiest solution
may be to simply put the card in another slot, as this will cause the BIOS to
reassign an IRQ for the device. You also may want to check your nic manual.
Some PnP device also have jumpers for manually setting the interrupt.
Joaquin Negron
Occasional Visitor

Re: Linux Bad IRQ setting...

Thanks for the suggestion Patrick, I really appreciate it. Unfortunately moving
the card to another slot did not make the BIOS reconsider its setting. Worst
of all, I think, is that I went as far as installing 2 network cards. My
surprise after dmesg | grep eth was that both cards were assigned IRQ0. It got
their addresses right though. Corel Linux is what I'm using. I'm not getting
the error message now though. But I need networking and DHCP working so that I
can connect to RoadRunner cable ISP. Any other suggestions, appreciate them...
Thanks again.
Patrick Watts_1
Frequent Advisor

Re: Linux Bad IRQ setting...

My only other suggestion would be to set the BIOS 'PNP OS' option to YES, boot
into windows 95/98 and let windows allocate system resources, then boot into
Linux. Perhaps if you could provide the make and model of your NE2000 I could
find out something more.
Joaquin Negron
Occasional Visitor

Re: Linux Bad IRQ setting...

I changed the NE2000 for an SMC 10/100. Here's what I get from dmesg | grep
eth:
eth0: SMC1211TX EZCard 10/100 (Real Tek RTL8139) at 0x1400, IRQ0,
00:e0:29:61:2d:8a (I'm positive rtl8139.o is the correct module).
Windows 98 resource settings for this NIC are:
IRQ9, Memory Range=06010000 - 060100FF, I/O Range=1400-14FF.
It looks like if I could tell Corel Linux to use IRQ9 instead IRQ0 the problem
might go away... I have no clue how to do this in Corel Linux (Debian
distribution). The machine's exact model is Pavilion 8570C. Thanks again for
you help...
Patrick Watts_1
Frequent Advisor

Re: Linux Bad IRQ setting...

Joaquin,

I am starting to suspect that maybe you have the "PnP OS" option set to
"Yes" in the BIOS. If this is the case, set it to "NO". Setting to YES tells
the BIOS to let the OS write the ESCD resource mappings instead of itself.
Also, you can check your current irq settings by looking in /proc/interrupts,
or get more detailed information with lspci -vv. You can also (alledgedly)set
the IRQ with the "setpci" command.
Chuck Slivkoff
Frequent Advisor

Re: Linux Bad IRQ setting...

You will need to set the "PnP OS Installed" option in BIOS to NO/FALSE. Linux
will not assign IRQ's to PnP PCI devices. ISA PnP devices are configurable
using isapnp. Disabling this in BIOS will force the BIOS to assign IRQ's to PnP
PCI devices.
Joaquin Negron
Occasional Visitor

Re: Linux Bad IRQ setting...

Thanks for your responses, Chuck and Patrick. I have booted the computer
hitting the F1 key to get into the BIOS but I just can't find a PCI PNP setting
to set to no/false. The only PNP settings I can set are for "Legacy ISA
devices", and all I can change them to is to "reserved" or "disabled". I'm
starting to believe the motherboard is just not supported by Linux. Anyway, how
can I get my hands on one of those BOISs that allows setting the PNP PCI to
"NO". Is this advisable?... Thanks again...

Joaquin.