Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

Linux Date

SOLVED
Go to solution
gigiz
Valued Contributor

Linux Date

Hi guys,
i have a problem with my Redhat ES4 with kernel
2.6.9-5elsmp v. 8664 installed on my DL380 servers.I have a problem with a date.
I set a date at the installation.
In few day a date advance to many hours.
If i re-set the date in few day the same problem.
I try to check a system time with date and the hardware time with clock i try to align their, but i have the same problem ....
Help me ...
Thanks a lot
Many point at any response .....
19 REPLIES
Rob Leadbeater
Honored Contributor

Re: Linux Date

Hi,

I take it you haven't configured NTP...

That will allow you to keep the server in sync. with an external time source.

It doesn't answer the question of why the system clock is getting so far ahead of itself, but it should keep the time right.

Hope this helps,

Regards,

Rob
Wouter Jagers
Honored Contributor

Re: Linux Date

Check out this link:
http://linux.derkeiler.com/Mailing-Lists/Fedora/2005-11/2688.html

I assume it's possible you'll need to have the mainboard replaced..

Anyway, worth to check before spending lots of time on it ;-)

Cheers,
Wout
an engineer's aim in a discussion is not to persuade, but to clarify.
Ivan Ferreira
Honored Contributor

Re: Linux Date

Your best option is to use NTP. The NTP configuration is very easy. See:

http://www.brandonhutchinson.com/Using_ntp_with_Red_Hat_Linux.html
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Wouter Jagers
Honored Contributor

Re: Linux Date

Problem is NTP will complain (and stop doing its job) when the clock is on too wild a rampage :-/

NTP is good, though.. you should really consider using it even when this problem is gone.

Cheers
an engineer's aim in a discussion is not to persuade, but to clarify.
gigiz
Valued Contributor

Re: Linux Date

ntp server is a warkaround is not a solution,
my customer want a solution ....
:-(
Rob Leadbeater
Honored Contributor

Re: Linux Date

Is this happening on *all* of the servers or just one ?

Just wondering if it's a hardware problem with the DL380 or something broken in RedHat...

What generation DL380 are you using ?

Cheers,

Rob
John Poff
Honored Contributor

Re: Linux Date

Hi,

You mention the kernel version as being "v.8664". What exactly does it show when you do a 'uname -r' on the box? Are you running a 64 bit kernel (x86_64)? If so, do you have 64 bit CPUs in the system? What does /proc/cpuinfo report about the CPUs?

I'm wondering if you have the right kernel.

JP
Stuart Browne
Honored Contributor

Re: Linux Date

I'm with John here.

In any case, the current release of kernel for RHEL4 is 2.6.9-42.0.10.EL. A 2.6.9-5 is not even U1! You've done your updates, yes?
One long-haired git at your service...
Matti_Kurkela
Honored Contributor

Re: Linux Date

I agree with John and Stuart above.

If you have a dual-core CPU, you *must* have at least U1, or you *will* have problems. If you read RedHat's list of supported hardware, it will note that U1 is a requirement on dual-core CPUs.

You can use the base ES4 CDs (with no update level, or "U0") to install a system with dual-core CPU(s), but you will get random crashes with high load and various timing problems. These will go away when you go to U1.

The easiest way is to register the system to RedHat Network and let up2date do its job.

By the way, if you have a x86_64 CPU, the system's model number should be DL385, not DL380.

MK
MK
gigiz
Valued Contributor

Re: Linux Date

HELP ME ....
The problem is on all my installed server, that are about 12.
I have a PROLIANT DL380 G4 SERVER, with PROCESSOR - INTEL XEON 3.60Hz, and are 64 bit kernel (x86_64).
Rob Leadbeater
Honored Contributor

Re: Linux Date

Have you read the previous posts ...?

There is lots of helpful information there.

Cheers,

Rob
John Poff
Honored Contributor

Re: Linux Date

The fact that it is happening on all 12 servers is good. That certainly rules out a hardware problem. Based on Stuart and Matti's advice, it would seem to any reasonable person that one might try updating the kernel. If it were me, I'd take one of the 12 boxes and try it. Just a suggestion.

JP
drb_1
Occasional Advisor

Re: Linux Date

From your frustration,
I suspect you may be unaware that in
typical front-end/engine style,
unix uses two clocks, and timezone locale
setting.

The hardware clock is like a watch for host.
It has a battery that maintains the time
when the host is off,
and which must be replaced/recharged
periodically.

The system clock is a virtual clock
that is set to match the hardware clock
when the host is booted, and daily(?)
thereafter.

The default time reported by date,
and otherwise often used,
is offset from the system clock,
according to timezone set with
environment variable "$TZ".



The hardware clock and the system clock
are normally set to UTC,
a.k.a. "internet time".

You can read the system clock setting as
ksh> date -u



This may be naive,
but is it possible that you have ntp setup,
and configured to use an ntp server,
that is improperly set.

This would account for resetting the time
after a few days.
(ntp would be doing its job of synchronizing
your host clocks.)

If ntp is in use and misconfigured,
after setting the time
and immediately seeing a correct report from
ksh> date -u
wait a few days, and rerun
ksh> date -u
to see major drift.


How can you determine if an ntp client
is running?
Where are the logs?

On my box, I know that ntp is being used,
(due to recent DST problems) but
/etc/ntp.conf and /etc/ntp.drift
appear unused,
ksh> ps -ef | grep ntp
and
ksh> netstat | grep 123
report nothing.




Is it possible that you have the timezone
($TZ) set inconsistently.
This would account for a fixed multi-hour
offset.
(When you reset the time with an inconsistent
timezone, you may offset the hardware clock,
by a fixed number of hours.)

If TZ is misconfigured,
after setting the time
and immediate report from
ksh> date -u
will be offset by hours.




When a hardware clock battery fails,
a drifting clock is usually the first symptom,
but before it reaches hours per day,
the host usually shuts down completely.


Hopefully helpful,
Court Campbell
Honored Contributor
Solution

Re: Linux Date

I would suggest running in s clockwise circle as fast as you can. Then maybe you can slow down the earths rotation; therefore, slowing down the system clock.
"The difference between me and you? I will read the man page." and "Respect the hat." and "You could just do a search on ITRC, you don't need to start a thread on a topic that's been answered 100 times already." Oh, and "What. no points???"
gigiz
Valued Contributor

Re: Linux Date

... Court you are a genius ... but sorry i'm not so fast .... have you a DELORIAN for back to the future ....!!!:-)
Wouter Jagers
Honored Contributor

Re: Linux Date

Funny thing:

We are considering the installation of a RedHat server on a VMWare ESX, running on AMD.

However, a supplier just told us he'd seen problems with such configurations before. The description he gave matches your problem exactly ! You seem to not be alone with this.

I've been looking around some more, and found this webpage, containing some potential fixes:

http://kb.vmware.com/selfservice/viewContent.do?externalId=1420

(note that this problem could also arise on non-virtualized boxes)

Let us know how it turns out, since I might soon be facing this issue myself ;-)

Cheers,
Wout
an engineer's aim in a discussion is not to persuade, but to clarify.
gigiz
Valued Contributor

Re: Linux Date

Ok .... i want try the upgrade, but i have a problem, i can't config my server for internet connection ....
I need to download the iso for my server and then install it ...
I want know the kernel version for my server and where i can download it ....

Thanks a lot
Steven E. Protter
Exalted Contributor

Re: Linux Date

Shalom,

Try a newer distribution of Red Hat. Use a PC to get it and burn the cd's. Red Hat 4 update 5 just got released and maybe its mature.

Your problems stem from the fact that the kernel doesn't support the hardware. After update 2 there is no problems with the DL380 class of server, we use a bunch of them.

If by chance you are using base RH 4 because thats all you have and you don't have a subscription to RHN, then consider http://www.centos.org

Its a legal port of RH 4, and its free.

No please read the thread, follow the good advice and let us know what happens.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
gigiz
Valued Contributor

Re: Linux Date

I have resolved with kernel upgrade.

:-)