cancel
Showing results for 
Search instead for 
Did you mean: 

Linux as X server for HP-UX

SOLVED
Go to solution
Kenneth_18
Frequent Advisor

Linux as X server for HP-UX

I wanted to display the CDE destop of a HP-UX server on my linux box display.

What I did is issue the command "X -query hpservername :1" on one of the virtual consoles.

However what happens is that I only get initial black screen and hourglass icon of the mouse curor. After that it just repeatedly just blanks out and shows the hourglass icon again. I even have to telnet into the linux box just to kill the X process since I cant even get a permanent non-balnking screen in the main gui screen of my linux box.

For connecting to a solaris box, its working perfectly fine.

Is there any configuration needed on my linux box or on the HP-server?
3 REPLIES
Kodjo Agbenu
Honored Contributor
Solution

Re: Linux as X server for HP-UX

Hello,

For me it works perfectly.
I guess your problem is linked to font server being used.

I would suggest you start the X font server on the HP-UX box as follows :

=> Edit /etc/rc.config.d/xfs and change the variable value from 0 to 1.

=> Type /sbin/init.d/xfs start to start the X font server.


Then tell your Linux X server to use the HP-UX machine's font server as follows :

X -query hpservername :1 -fn tcp/hpservername:7000


IMPORTANT REMARK : if you have an international keyboard, you may need the "AltGr" for certains characters (|, #, @, etc...). To be able to use the "AltGr" key, you must disable XKB extensions in the CDE startup files.
To do that, go to the HP-UX machine :

cd /etc/dt/config/Xsession.d

Create a new file (let's say "xkbdisable") with the following two lines :

#!/usr/bin/ksh
export XKB_DISABLE=1

Set the permissions of this file as follows :

chown bin:bin /etc/dt/config/Xsession.d/xkbdisable
chmod 555 /etc/dt/config/Xsession.d/xkbdisable


To make sure that changes are effective, you have to logout from your CDE desktop (from Linux machine) and login again.

Good luck.

Kodjo
Learn and explain...
dirk dierickx
Honored Contributor

Re: Linux as X server for HP-UX

This is not directly related to your problem just a tip when using linux as an X terminal.

use 8bit color depth, if not some applications may look wierd or not start up at all.
Jochen Heuer
Respected Contributor

Re: Linux as X server for HP-UX

Not directly related but you can run an X-Server inside your local X session with Xnest. There you can also have a different color depth and so on. Very nice!
Well, yeah ... I suppose there's no point in getting greedy, is there?