cancel
Showing results for 
Search instead for 
Did you mean: 

Linux on presario 2100

SOLVED
Go to solution
Alan Bradley
Occasional Visitor

Linux on presario 2100

I have a 2105us with the o2micro PCMCIA controler. I am trying to get (any) linux distro to work. I have tried to disable the PCMCIA kernel but it still detecks it and locks up during boot. Has any one else seen this issue? And/Or is thereany documentation on how to get this to work?

I would like to have access to my pcmcia, but it is no necessary.

Thanks
Alan
Can Smeg Will Smeg
4 REPLIES
Bruce Copeland
Trusted Contributor
Solution

Re: Linux on presario 2100

I'm not sure what exactly you mean when you say you've tried to disable the PCMCIA. If you haven't tried starting the install with the nopcmcia boot parameter, you probably should. Many notebook owners have to use this parameter and/or the nousb parameter. In any event, take a look at the following two sites:

http://home.attbi.com/~foglem/2105us.html
http://sole.infis.univ.trieste.it/~drzeus/presario2120ea.html

Bruce
Sergejs Svitnevs
Honored Contributor

Re: Linux on presario 2100

RedHat: You might try installing using "linux nopcmcia" -- the nopcmcia option tells the kernel to ignore any PCMCIA controllers on the system.

Mandrake: "linux noauto nomce"

Regards,
Sergejs
Alan Bradley
Occasional Visitor

Re: Linux on presario 2100

First of all Cudos to Bruce!

This (http://home.attbi.com/~foglem/2105us.html ) site gives you 90% of what you need to know. Here is what is missing :

1. Start RH 8.0 install.

2. After the first reboot it will lock up at when it tries to load the PCMCIA. power off the laptop at this point, and insert RH install disk 1 and press for recovery mode.

3. Type linux recovery .

4. This will try and detect the partitions that you just created. When you get to a command prompt type chroot /mnt/sysimage .

5. Change directory to the /etc/rc.d/ directory , cd rc.d . dir

6. There are 7 directory(rc0.d - rc6.d) here that you will need to go into. Find the file S##pcmcia or K##pcmcia and rename them to S09pcmcia or K09pcmcia like this : mv S24pcmcia S09pcmcia. (stupid mistake) Linux is VERY CASE SENSITIVE so be very careful.

His site recomended changeing it to S01pcmcia. When I used that setting my laptop was VERY SLOW. S10pcmcia locked up my system and S9pcmcia worked perfect.

Good luck to those who need it.

Alan

Can Smeg Will Smeg
Al Stone
Occasional Visitor

Re: Linux on presario 2100

You might also want to check out these sites:

http://www.linux-laptop.net
and
http://www.tuxmobil.org.

Ciao,
al