Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

MAXDSIZ doesn't change even after rebuilding kernel

SOLVED
Go to solution
Ajay_14
Occasional Advisor

MAXDSIZ doesn't change even after rebuilding kernel

Hi,

I need to change the maxdsiz parameter on a hpux 11i machine. I changed the parameters using kmtune command and reconfigured the kernel. After booting, still the value is displayed as 0X40000000 instead of 2039480320.

Can anybody point me to the right way of modifying. Also, can i specify in plain numbers or do i need to specify in 0x..... format ( btw - how to calculate this value ).

thanx.
8 REPLIES
Sridhar Bhaskarla
Honored Contributor
Solution

Re: MAXDSIZ doesn't change even after rebuilding kernel

Hi Ajay,

maxdsiz is a 32bit parameter. There is no point setting it to 2GB as the maximum segment you can have is only 1GB even if it allows. I believe you are interested in maxdsiz_64bit. I compile the kernel this way.

#cp /stand/system /stand/system.110904
#/usr/lbin/sysadm/system_prep -s /stand/system
(edit it and change the value)
#mk_kernel -o /stand/vmunix
#cp /stand/system /stand/build/system
#kmupdate
#shutdown -r now

Converting from hex to dec and vice versa is real easy. For ex., if you want to find out the dec value of a hex number do

printf "%x" 2039480320

To get the otherway

printf "%d" 0x40000000

But you can specify the value in decimal notation itself. If you don't put 0x, then it will understand it as decimal.


-Sri
You may be disappointed if you fail, but you are doomed if you don't try
Ajay_14
Occasional Advisor

Re: MAXDSIZ doesn't change even after rebuilding kernel

Hi. Sri,

I specified it in Decimal format, i.e
kmtune -s maxdsiz=2039480320 -S /stand/build/system

but still, it reflects the old value.
I did the same steps that you specified.

Any inputs... or is it that if the value is greater than 1 GB it will not be applied ?

thanx
Sridhar Bhaskarla
Honored Contributor

Re: MAXDSIZ doesn't change even after rebuilding kernel

Does your /stand/system (not /stand/build/system) reflect correct parameter?. Copy /stand/build/system as /stand/system and then try 'kmtune -l -q maxdsiz' command.

How did you specify the kernel file with your "mk_kernel" command?. It expects the default system file in /stand rather than /stand/build.

You can increase upto 4GB on 11i.

-Sri
You may be disappointed if you fail, but you are doomed if you don't try
Ajay_14
Occasional Advisor

Re: MAXDSIZ doesn't change even after rebuilding kernel

These are the commands that i used :

# kmtune -s maxdsiz=2039480320 -S /stand/build/system
# cd /stand/build
# /usr/lbin/sysadm/system_prep -s system
# /usr/sbin/mk_kernel -s system
# mv /stand/system /stand/system.prev
# mv /stand/vmunix /stand/vmunix.prev
# mv /stand/dlkm /stand/dlkm.vmunix.prev
# mv /stand/build/system /stand/system
# kmupdate /stand/build/vmunix_test
# shutdown -ry 0

In the above steps, the new system file is copied to /stand/system , but after the reboot the changes are not being displayed.

Ivajlo Yanakiev
Respected Contributor

Re: MAXDSIZ doesn't change even after rebuilding kernel

Hi

Use sam and change value.
Rebuild kernel. If you have right system file you will get right kernel.

SAM will help you and point all changes in right system file.







Sridhar Bhaskarla
Honored Contributor

Re: MAXDSIZ doesn't change even after rebuilding kernel

You got all the commands in incorrect order. /stand/build/system is only for SAM's use.

#cd /stand
#/usr/lbin/sysadm/system_prep -s system
#kmtune -s maxdsiz=2039480320 -S /stand/system (note the difference here)
#cp system build/system
#mk_kernel -o /stand/vmunix
#kmupdate

Don't move the files manually. mk_kernel runs kmupdate automatically and move it during the shutdown. (the second kmupdate is just redundant).

Try it again..

-Sri
You may be disappointed if you fail, but you are doomed if you don't try
Ajay_14
Occasional Advisor

Re: MAXDSIZ doesn't change even after rebuilding kernel

Hi. Sri,

It worked out.

Thanx a lot.

regds...
Ajay_14
Occasional Advisor

Re: MAXDSIZ doesn't change even after rebuilding kernel

Problem solved