Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

MC/ServiceGuard on linux problem

SOLVED
Go to solution
Chad Wigal
Occasional Visitor

MC/ServiceGuard on linux problem

Greetings,

I've just installed MCSG on two RedHat AS2.1 boxes and I'm having a problem generating an initial cluster config template file. Specifically, I am executing:

cmquerycl -v -n bones -n crusher -q gimli -C /usr/local/cmcluser/conf/mis2.config

The output is as follows:

[root@bones conf]# cmquerycl -v -n bones -n crusher -q gimli -C /usr/local/cmcluser/conf/mis2.config

Begin checking the nodes...
Looking for other clusters ... Done
Gathering configuration information ............. Done
Failed to gather configuration information.

The only log entry that I can find is in /var/log/messages:

Oct 10 16:07:40 bones cmclconfd[3857]: Unable to stat /usr/local/cmcluster/conf/cmclconfig, No such file or directory

This entry is made in the messages file on both nodes.

I was under the impression that the cmclconfig file wasn't created until after cmapplyconf is run (I didn't think that it needed to exist before I run cmquerycl to generate an initial config template file).

Has anybody else run across this? Any help would be greatly appreciated. Thanks!

Chad Wigal
Senior MIS Consultant
Vanderbilt University
2 REPLIES
John Poff
Honored Contributor
Solution

Re: MC/ServiceGuard on linux problem

Hi,

Just a dumb question, but you do have a /usr/local/cmcluster/conf/ directory on each system?

Also, in your command line you have:

... -C /usr/local/cmcluser/conf/mis2.config

Is that just a typo or should that be /usr/local/cmcluster/conf ... ?

JP
Chad Wigal
Occasional Visitor

Re: MC/ServiceGuard on linux problem

Thanks for replying John. Yes, I did have that directory on each system, and the argument for the "-C" option is to specify the name of the template config file that the command was supposed to generate.

I've actually fixed the problem, though. I was using the "tg3" module for my broadcom gig ethernet cards instead of the "bcm5700" module. The tg3 module worked fine until I started configuring serviceguard. On a hunch, I decided to download and install the latest bcm5700 driver from compaq, modify my /etc/modules.conf file to make my nics use it, and everything started working as expected. Phew...

Anyway, thanks again for the reply!